summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2018-01-26 02:33:52 +0200
committerDavid Seifert <soap@gentoo.org>2018-02-06 10:56:15 +0100
commit5a1bcdacef86ba2ae53ae6fb4b6d500b215c6925 (patch)
tree5b31cddf5599328951a1d8b84f99742ea799b778
parentsys-kernel/gentoo-sources: remove old kernel (diff)
downloadgentoo-5a1bcdac.tar.gz
gentoo-5a1bcdac.tar.bz2
gentoo-5a1bcdac.zip
app-text/scdoc: New package
initial version 1.2.3 Closes: https://github.com/gentoo/gentoo/pull/6961
-rw-r--r--app-text/scdoc/Manifest1
-rw-r--r--app-text/scdoc/metadata.xml15
-rw-r--r--app-text/scdoc/scdoc-1.2.3.ebuild38
3 files changed, 54 insertions, 0 deletions
diff --git a/app-text/scdoc/Manifest b/app-text/scdoc/Manifest
new file mode 100644
index 000000000000..23793d69d4dc
--- /dev/null
+++ b/app-text/scdoc/Manifest
@@ -0,0 +1 @@
+DIST scdoc-1.2.3.tar.xz 6920 BLAKE2B 7cafe512016dc7dcfa56216cac3f3fd99ef05dfefb67ce8dba9726c8d60b49829f444f66c62c4ee9a0d2464749510ba60ac0b72996c656e3d66aef80e5ef0546 SHA512 1d5170d2a73ebccdb83ffffbec5ec431aab54b02eea5b062d0210c98636d059dc1fa57bfc1573a0e510cc8849759f6bb6462e3f5a78f22273a10bf47f2e0a2c6
diff --git a/app-text/scdoc/metadata.xml b/app-text/scdoc/metadata.xml
new file mode 100644
index 000000000000..442a873c810e
--- /dev/null
+++ b/app-text/scdoc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hilobakho@gmail.com</email>
+ <name>Mykyta Holubakha</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">swaywm/sway</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/scdoc/scdoc-1.2.3.ebuild b/app-text/scdoc/scdoc-1.2.3.ebuild
new file mode 100644
index 000000000000..fb88bae39fea
--- /dev/null
+++ b/app-text/scdoc/scdoc-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
+SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/snapshot/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//' Makefile || die 'Failed to remove -Werror'
+ sed -i 's/CFLAGS=/CFLAGS+=/' Makefile || die 'Failed to patch makefile'
+}
+
+src_compile() {
+ MY_HS="./scdoc"
+ if tc-is-cross-compiler; then
+ tc-export_build_env
+ MY_HS="./hostscdoc"
+ MAKEOPTS+=" HOST_SCDOC=./hostscdoc"
+ emake scdoc OUTDIR="${S}/.build.host" CC=$(tc-getBUILD_CC) \
+ CFLAGS="${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
+ mv scdoc hostscdoc || die 'Failed to rename host scdoc'
+ fi
+ emake LDFLAGS="${LDFLAGS}" HOST_SCDOC="${MY_HS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" HOST_SCDOC="${MY_HS}" install
+}