summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-06 22:03:36 +0000
committerSam James <sam@gentoo.org>2023-02-06 22:03:48 +0000
commit5a28bd967d8a385702969116e6a9d6aa47be6644 (patch)
tree57ab0d942397a7bafbc2569f2b507055578266ce
parentgames-arcade/berusky: fix build w/ gcc 12 (diff)
downloadgentoo-5a28bd967d8a385702969116e6a9d6aa47be6644.tar.gz
gentoo-5a28bd967d8a385702969116e6a9d6aa47be6644.tar.bz2
gentoo-5a28bd967d8a385702969116e6a9d6aa47be6644.zip
sys-fs/ext3grep: EAPI 8, fix build w/ gcc 12
Closes: https://bugs.gentoo.org/890987 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.2-r1.ebuild (renamed from sys-fs/ext3grep/ext3grep-0.10.2.ebuild)15
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-missing-cassert-include.patch11
2 files changed, 19 insertions, 7 deletions
diff --git a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild b/sys-fs/ext3grep/ext3grep-0.10.2-r1.ebuild
index 1c8c5533ad98..6be20c71aa3f 100644
--- a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
+++ b/sys-fs/ext3grep/ext3grep-0.10.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Recover deleted files on an ext3 file system"
HOMEPAGE="https://code.google.com/p/ext3grep/"
@@ -12,21 +12,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug pch"
-DEPEND="sys-fs/e2fsprogs
+DEPEND="
+ sys-fs/e2fsprogs
virtual/os-headers
- virtual/pkgconfig"
-
-DOCS="NEWS README"
+"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${PN}-0.10.1-gcc44.patch"
"${FILESDIR}/${P}-include-unistd_h-for-sysconf.patch"
"${FILESDIR}/${P}-new-e2fsprogs.patch"
"${FILESDIR}/${P}-newer-e2fsprogs.patch"
+ "${FILESDIR}/${P}-missing-cassert-include.patch"
)
src_configure() {
- myeconfargs=(
+ local myeconfargs=(
$(use_enable debug)
$(use_enable pch)
)
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-missing-cassert-include.patch b/sys-fs/ext3grep/files/ext3grep-0.10.2-missing-cassert-include.patch
new file mode 100644
index 000000000000..34e60b00a659
--- /dev/null
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-missing-cassert-include.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/890987
+--- a/src/custom.cc
++++ b/src/custom.cc
+@@ -44,6 +44,7 @@
+ #include "init_consts.h"
+ #include "print_inode_to.h"
+ #include <sys/time.h>
++#include <cassert>
+ #include <cstring>
+ #include <ctime>
+