summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-31 22:07:29 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-31 22:07:29 +0100
commit5a397e4f1fc191fd4b7992d0ab964cea2f3dae70 (patch)
treea3d276eb784d61c6c624be5407a16fcdfdeacd08
parentdev-ml/opam-solver: 2.1.2 bump (diff)
downloadgentoo-5a397e4f.tar.gz
gentoo-5a397e4f.tar.bz2
gentoo-5a397e4f.zip
dev-ml/opam-client: 2.1.2 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/opam-client/Manifest1
-rw-r--r--dev-ml/opam-client/opam-client-2.1.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/opam-client/Manifest b/dev-ml/opam-client/Manifest
index f220f1c24723..879ecc216aa3 100644
--- a/dev-ml/opam-client/Manifest
+++ b/dev-ml/opam-client/Manifest
@@ -4,3 +4,4 @@ DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e5137
DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c679519895aa2568f0c2d199d4ba9d6ae948a4fc418cfd26cc65079eb6ef3545f24a35e08c969d215529664a80d0c9147 SHA512 e00da74d7baef62319e884e3a05112bcf86a02d887c274bd15fb0d15bb8198e9a37a421f388bec3fce198e7a1b4d37024b18609dc65978c6ee8a7889df9bd608
DIST opam-2.1.0.tar.gz 825966 BLAKE2B 42ab8ad2825e4e167618ece7bd2ce77ff055d584039fe2f644fa1c3e99d175cc7047f32bda53599af4fb177d844970883125cebca823024d1bc43a34857f20c5 SHA512 c0060e609c49a12dc8f64accef990aa593db818b72df3984fb9b4b22d8678b46c515916c84134a62dab614c716b61788eadc954d295f32c1f27d38aec22b3edf
DIST opam-2.1.1.tar.gz 818555 BLAKE2B 0f3e94c723774c38a5ad553f58fa796836eb8ef80add977a0e677df026225b5cd737409717026cfbc95388094a0434eb9ff865043c1781eba228f1499c9ab996 SHA512 fb46bc8f12e49c2da95c5f8669f55fb93710ee826827538852c3091ec2c714c082137373fa9e1ad3f53f107b1fae6c2abd0b6e5f84f7756bd3b38e57978f080e
+DIST opam-2.1.2.tar.gz 818848 BLAKE2B ffb50f3cf1421aa9bff6877d636a3d1d1cc2c2e3961ecd60fcae8a35b069c8d22e7a36bf17cb8166533621a3c85a82195fd3fa646b2fd8dcea9e626b61d5b86c SHA512 bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396
diff --git a/dev-ml/opam-client/opam-client-2.1.2.ebuild b/dev-ml/opam-client/opam-client-2.1.2.ebuild
new file mode 100644
index 000000000000..e27961dead03
--- /dev/null
+++ b/dev-ml/opam-client/opam-client-2.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam client libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-repository-${PV}:=
+ ~dev-ml/opam-state-${PV}:=
+ ~dev-ml/opam-solver-${PV}:=
+ dev-ml/opam-file-format:=
+ dev-ml/re:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( sys-apps/bubblewrap )"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}