summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-22 23:41:45 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-22 23:44:31 -0700
commit5a39e4c7956f7779d81f5b9d50f6a182a5569241 (patch)
tree563a5fe01fdac9f9fd74ee40b9e7561fb8de918c
parentnet-libs/glib-networking: Version bump to 2.72.0 (diff)
downloadgentoo-5a39e4c7.tar.gz
gentoo-5a39e4c7.tar.bz2
gentoo-5a39e4c7.zip
gnome-extra/gnome-weather: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-42.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index e63e7101c902..c89ba1d254ef 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1 +1,2 @@
DIST gnome-weather-41.0.tar.xz 943500 BLAKE2B a349360f001bc8a3246227fcdad51bdb115db382650ead36e9768c002f0d7892296610320bf90bb569915c72c48492002268f8aa049055ebc687dc08052d6170 SHA512 f625a83ecfffe1ad58aa268b6ab3009504f839f3d56e52c642bc23ee32c0b51638888de17a1b4bc0990b2fd6718a7266fe5cd79230594a06ae58a816308b2b99
+DIST gnome-weather-42.0.tar.xz 233552 BLAKE2B 64cdefbcdc93359518b4e08564eafc3235d7b2ab92d69d79b558c5d4f5ce03425d87fb8e7e351165d00983eab5807ebc05aa7c0eb604a618d135afb66170c8ff SHA512 10471a32adc148fad393e03098396a3cfccc75d1cd18985cdd2c287927213aeb493f2878ea986e1d3a3af4b1d3f439afcdb96833d849bbd5fbe7aebb1d1992e6
diff --git a/gnome-extra/gnome-weather/gnome-weather-42.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-42.0.ebuild
new file mode 100644
index 000000000000..82a788f80ae0
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-42.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=gui-libs/gtk-4.5:4
+ >=dev-libs/gjs-1.71.0
+ >=app-misc/geoclue-2.3.1:2.0
+ >=gui-libs/libadwaita-1.0.0:1=
+ >=dev-libs/libgweather-3.90.0:4=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}