summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-19 10:55:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-19 10:55:20 +0100
commit5a4382dcce9984d1bfae207b20848cee79c84936 (patch)
tree45c414dff2be40210a74870536b349d63412a7fe
parentdev-python/pydocstyle: Remove more pip calls (diff)
downloadgentoo-5a4382dcce9984d1bfae207b20848cee79c84936.tar.gz
gentoo-5a4382dcce9984d1bfae207b20848cee79c84936.tar.bz2
gentoo-5a4382dcce9984d1bfae207b20848cee79c84936.zip
dev-python/cbor2: Skip failing tests on 32-bit targets
Closes: https://bugs.gentoo.org/755413 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cbor2/cbor2-5.2.0.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/dev-python/cbor2/cbor2-5.2.0.ebuild b/dev-python/cbor2/cbor2-5.2.0.ebuild
index a423f3fda5a9..2c4aa4f6195e 100644
--- a/dev-python/cbor2/cbor2-5.2.0.ebuild
+++ b/dev-python/cbor2/cbor2-5.2.0.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -11,23 +10,13 @@ DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~x86"
-BDEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-RDEPEND="${DEPEND}"
+distutils_enable_tests pytest
python_prepare_all() {
-
# remove pytest-cov dep
sed -e "s/pytest-cov//" \
-e "s/--cov //" \
@@ -36,4 +25,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-distutils_enable_tests pytest
+python_test() {
+ local deselect=()
+
+ if use arm || use x86; then
+ # https://github.com/agronholm/cbor2/issues/99
+ deselect+=(
+ tests/test_decoder.py::test_huge_truncated_bytes
+ tests/test_decoder.py::test_huge_truncated_string
+ )
+ fi
+
+ epytest ${deselect[@]/#/--deselect }
+}