summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-30 07:34:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-30 07:45:38 +0200
commit5a48b700f9bddd5f77757a04bdfdf7b20d324d85 (patch)
tree5a8b93dfbf3eb403f449e2af6054a5d7de51bd30
parentdev-python/mako: Bump to 1.2.2 (diff)
downloadgentoo-5a48b700.tar.gz
gentoo-5a48b700.tar.bz2
gentoo-5a48b700.zip
dev-python/pytest-xprocess: Bump to 0.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.20.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 34866c23f07f..2483d8d0a2c1 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-xprocess-0.19.0.tar.gz 30217 BLAKE2B 1990a48036469f990451b8eb12a05b7f10295532a72567f95d95d6e12f192f0b76bd511a994c5b8f0e3725f0edb76c4991351fe68e82f351d9b47a9921230f11 SHA512 d41c3c91892d6126455e9b834ada7aad5d0fa67603eff14a73309589e269a21de032e8192e9bde4d6656aaa4984dd0c98242d54b0e2b24a43b85c8ed81a00d89
+DIST pytest-xprocess-0.20.0.tar.gz 30342 BLAKE2B 8e66ad321224cb8e702721b0936c56b65be5aee9330a233c710519303679f2d1eea03825fe4326ffd2811f6fe4c37db217a2c0c34561742bd2c849ddcae7284e SHA512 bce022c924db94f53549c1df5547a8df7390806bb99d817f152f1e5fb946fef60f2447a31dc519577c1b54d6a7adeb7d7d996a28e7784918622db5ccfd0b035b
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.20.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.20.0.ebuild
new file mode 100644
index 000000000000..ad5324f444dd
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.20.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest