summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-21 09:11:32 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-21 09:23:38 -0500
commit5a6ba41e610759b368f0298035eec2f762994240 (patch)
tree4a0ef62e8319c210190f3792264e2efa7f1e6f78
parentnet-misc/ytfzf: add 2.1 (diff)
downloadgentoo-5a6ba41e.tar.gz
gentoo-5a6ba41e.tar.bz2
gentoo-5a6ba41e.zip
net-misc/yt-dlp: add 2022.1.21
Not using PEP517 yet given this will go stable too soon. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2022.1.21.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index d64743144923..8f71b07b5293 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2021.12.27.tar.gz 2102852 BLAKE2B 69a3a9c916771ab2e1b8f86bbc43e03d0543801f587708b638348088d4454aff8ac93420fd8bd2ebb4f493c74acdf23f08a9495dbcdad77d840a95cfece4aa6b SHA512 2c687493736fabe131481d6bf8df13afc1959ac1458675bfe3c4273df7bb64218f84e07ea324b664b0a52c3e39b3e10999e81bc907bfc98a71a28c92dca90737
+DIST yt-dlp-2022.1.21.tar.gz 2160713 BLAKE2B 30ed1c7a317318ca6a6ee183ba8e4396420eb090ddacc64ddde2bb4077c7c45b01c00caca90d1b8be501f90c71407e27d6ef847fdbfea8bed488771f9b59bbe1 SHA512 5844d49dbf50842d4d51dbb00c16efea816322888d16a8dbce16f976f0dd1625ec8243fcdc07e721180a2f02cf14ebaa0d83a1437e331b4aa68c404db3f1e9f4
diff --git a/net-misc/yt-dlp/yt-dlp-2022.1.21.ebuild b/net-misc/yt-dlp/yt-dlp-2022.1.21.ebuild
new file mode 100644
index 000000000000..57cb468d48c6
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2022.1.21.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 optfeature
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri setup.py \
+ -e "s/'(pycryptodome)x'/'\1'/" \
+ -e "s/'(mutagen|websockets)',?//g" || die
+}
+
+python_test() {
+ epytest -m 'not download' -p no:markdown
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ local sitedir=$(python_get_sitedir)
+ dosym yt_dlp "${sitedir#${EPREFIX}}"/youtube_dl
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ newbin - youtube-dl <<-EOF
+ #!/usr/bin/env sh
+ exec yt-dlp --compat-options youtube-dl "\${@}"
+ EOF
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]] ||
+ ver_test ${REPLACING_VERSIONS} -lt 2021.10.22-r2; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}