summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-28 12:23:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-28 12:24:53 +0200
commit5a7998d8e7c58d0eb987cd6d5a50acd7635955e1 (patch)
tree44da921d2a427722d0583cfd5e3e8f2fed0490f6
parentmedia-sound/cmus: fixed building of 2.9.1 on ppc (diff)
downloadgentoo-5a7998d8.tar.gz
gentoo-5a7998d8.tar.bz2
gentoo-5a7998d8.zip
dev-python/requests-mock: Bump to 1.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/requests-mock/Manifest1
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
index e67982eaedcd..ee0bf9cf47b9 100644
--- a/dev-python/requests-mock/Manifest
+++ b/dev-python/requests-mock/Manifest
@@ -1,2 +1,3 @@
DIST requests-mock-1.8.0.tar.gz 59794 BLAKE2B 2bdcd180ea793a02cf34eda356d90c0e338cec6f3fb718564026d28ea06ac975073f291be9cb685f012c803fdeca1fe29139537529e292b91a3356f0b781f97a SHA512 252bce965e0fca03cd5ce09912c726045f9c632e90bfee13b06c9f3e2c6b70eab7f39cf8e7efb3b7d2cf2b5d79cc5c5ba6e2379b3d48ce33bf78861ada911918
DIST requests-mock-1.9.0.tar.gz 66243 BLAKE2B 33602e85376d7812b8f4b35bf657c905ddc7db4d85e3de1f70d38871c90c42fc886e99bce3dc45079b6c8ac8e3e6b0b5291d4acda31d26045396d4ed505c3faf SHA512 1382077357a13dbec65cc4226b628ff6b55348422d9f0e9e2311c85affbc40437d22c2f95fa305303a86decc765a6228366f27eea76e254da194789b1d8fb610
+DIST requests-mock-1.9.1.tar.gz 66782 BLAKE2B 5457d359bf93f3f1e335481e44c1e9a391ee88c648b3c385806274e2c39ae3a69268d792dfc2e4609f2ccebd47dc2a3bb488f11b1b479c010a4194fe5cdc3be6 SHA512 96a8a787daa7d42796baf2807543ca18c27f595e101fd230cd392eb2417b3b0925b977a6fc49d70e21362e5b647cac201cb9f3968301ce2702772ddd85cf7094
diff --git a/dev-python/requests-mock/requests-mock-1.9.1.ebuild b/dev-python/requests-mock/requests-mock-1.9.1.ebuild
new file mode 100644
index 000000000000..930d9082097b
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Disable reno which only works inside a git repository
+ sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
+ # Remove the release notes section which requires reno
+ rm doc/source/release-notes.rst || die
+ sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+ # Disable a test which requires purl (not in the tree)
+ sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
+ tests/test_adapter.py || die
+ distutils-r1_python_prepare_all
+}