summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-06 09:48:05 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-06 10:58:04 -0500
commit5ab6ca450b20a9e3afe4327ee4922c6c4576ed2f (patch)
treeee2447dfdb91cb0dd1a7b986fda451d16790380e
parentmedia-tv/kodi: 18.0_beta5 version bump (diff)
downloadgentoo-5ab6ca450b20a9e3afe4327ee4922c6c4576ed2f.tar.gz
gentoo-5ab6ca450b20a9e3afe4327ee4922c6c4576ed2f.tar.bz2
gentoo-5ab6ca450b20a9e3afe4327ee4922c6c4576ed2f.zip
media-plugins/kodi-inputstream-rtmp: 2.0.4 version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--media-plugins/kodi-inputstream-rtmp/Manifest1
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.4.ebuild36
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild13
-rw-r--r--media-plugins/kodi-inputstream-rtmp/metadata.xml2
4 files changed, 45 insertions, 7 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/Manifest b/media-plugins/kodi-inputstream-rtmp/Manifest
index fa03c93a5e22..44ba817d9a42 100644
--- a/media-plugins/kodi-inputstream-rtmp/Manifest
+++ b/media-plugins/kodi-inputstream-rtmp/Manifest
@@ -1,2 +1,3 @@
DIST kodi-inputstream-rtmp-1.0.4.tar.gz 7271 BLAKE2B c76b46fc1ba1bbe45084071ee0521b8f421a87886723abce3103867f8c542dbee364c9cb64a3e7237c59cfcc9afd910bb4ba5b749d5e1f6efa4ac215b1ced26d SHA512 659990b2cbe6e9119c650e151aaae0ccd33f8b9f5d6efd1436f4cb6c78beb51c8fae528b844278348066e1b10fe2a7fa6c05e32b54be82f5a750a5a14c8bd9d2
DIST kodi-inputstream-rtmp-1.0.5.tar.gz 7271 BLAKE2B dfc7a80684d0c872761baf4e8603b491b6530cb0e8a5aad782f18165cb15ec54aaf7557b877eab74c87a46d68481aefecde2f0b15fc748c5a7800593f9033a45 SHA512 7a58ec265586fc0ffc8b1021aa1529d171c8ea14202f80b443d51dbfbfd8f0424a2b5f94687d302a3681e2931ac268e89e8d2e82635ac5b792cc8c9bd8f020af
+DIST kodi-inputstream-rtmp-2.0.4.tar.gz 18259 BLAKE2B 714090d52b1e46e79b88b34b3a400edb444668be2856eb92b61769ecec802be4a7fc1ab73380febbf0cb277b6a1758f2f4f81efb6d1c6c1d266691de6071f7cb SHA512 ac7a7f3f40f4c7d4ec176299ae0d8dd389f1e041d6633a65190e7e8a0a87e87142ebf4f80a36b7429524f7d1571ce5d1708ac753edae695b1d1d84de73e5d88f
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.4.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.4.ebuild
new file mode 100644
index 000000000000..b9b53d260348
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/inputstream.rtmp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
index 28be9b91015b..c866d60112af 100644
--- a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,19 +6,20 @@ EAPI=6
inherit cmake-utils kodi-addon
DESCRIPTION="Kodi's RTMP inputstream addon"
-HOMEPAGE="https://github.com/notspiff/inputstream.rtmp"
+HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
SRC_URI=""
case ${PV} in
9999)
SRC_URI=""
- EGIT_REPO_URI="https://github.com/notspiff/inputstream.rtmp.git"
+ EGIT_REPO_URI="https://github.com/xbmc/inputstream.rtmp.git"
inherit git-r3
;;
*)
+ CODENAME="Leia"
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/notspiff/inputstream.rtmp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/inputstream.rtmp-${PV}"
+ SRC_URI="https://github.com/xbmc/inputstream.rtmp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}-${CODENAME}"
;;
esac
@@ -27,7 +28,7 @@ SLOT="0"
IUSE=""
DEPEND="
- =media-tv/kodi-9999
+ ~media-tv/kodi-9999
media-video/rtmpdump
"
RDEPEND="
diff --git a/media-plugins/kodi-inputstream-rtmp/metadata.xml b/media-plugins/kodi-inputstream-rtmp/metadata.xml
index a9d8bb311bc5..1ebb385c856d 100644
--- a/media-plugins/kodi-inputstream-rtmp/metadata.xml
+++ b/media-plugins/kodi-inputstream-rtmp/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<longdescription>Kodi's RTMP inputstream addon</longdescription>
<upstream>
- <remote-id type="github">notspiff/inputstream.rtmp</remote-id>
+ <remote-id type="github">xbmc/inputstream.rtmp</remote-id>
</upstream>
</pkgmetadata>