summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-21 10:32:47 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-21 11:15:28 +0200
commit5ac83c36fe2ffcaf3f9b4b6ba735741503ae2ba5 (patch)
tree2e26ca915d8ad51e8f55f8851ce2090ca255b4f5
parentdev-python/clang-python: Reorder ebuild vars in 9+ (diff)
downloadgentoo-5ac83c36fe2ffcaf3f9b4b6ba735741503ae2ba5.tar.gz
gentoo-5ac83c36fe2ffcaf3f9b4b6ba735741503ae2ba5.tar.bz2
gentoo-5ac83c36fe2ffcaf3f9b4b6ba735741503ae2ba5.zip
dev-python/lit: Reorder ebuild vars in 9+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lit/lit-10.0.0.9999.ebuild4
-rw-r--r--dev-python/lit/lit-9.0.0.9999.ebuild4
-rw-r--r--dev-python/lit/lit-9.0.0.ebuild3
3 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/lit/lit-10.0.0.9999.ebuild b/dev-python/lit/lit-10.0.0.9999.ebuild
index d4566ae8be57..32320b7920e1 100644
--- a/dev-python/lit/lit-10.0.0.9999.ebuild
+++ b/dev-python/lit/lit-10.0.0.9999.ebuild
@@ -9,6 +9,8 @@ inherit distutils-r1 git-r3 multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
+S=${WORKDIR}/${P}/utils/lit
+
EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"
@@ -18,8 +20,6 @@ KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"
-S=${WORKDIR}/${P}/utils/lit
-
# Tests require 'FileCheck' and 'not' utilities (from llvm)
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/lit/lit-9.0.0.9999.ebuild b/dev-python/lit/lit-9.0.0.9999.ebuild
index 289c81bd0a51..c9fb8cb28154 100644
--- a/dev-python/lit/lit-9.0.0.9999.ebuild
+++ b/dev-python/lit/lit-9.0.0.9999.ebuild
@@ -9,6 +9,8 @@ inherit distutils-r1 git-r3 multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
+S=${WORKDIR}/${P}/utils/lit
+
EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"
EGIT_BRANCH="release_90"
@@ -19,8 +21,6 @@ KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"
-S=${WORKDIR}/${P}/utils/lit
-
# Tests require 'FileCheck' and 'not' utilities (from llvm)
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/lit/lit-9.0.0.ebuild b/dev-python/lit/lit-9.0.0.ebuild
index 7eb1e8081689..80e7699557cd 100644
--- a/dev-python/lit/lit-9.0.0.ebuild
+++ b/dev-python/lit/lit-9.0.0.ebuild
@@ -10,6 +10,7 @@ MY_P=llvm-${PV/_/}.src
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}/utils/lit
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -17,8 +18,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd"
IUSE="test"
RESTRICT="!test? ( test )"
-S=${WORKDIR}/${MY_P}/utils/lit
-
# Tests require 'FileCheck' and 'not' utilities (from llvm)
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]