summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-06-25 23:12:57 +0200
committerMichał Górny <mgorny@gentoo.org>2016-06-25 23:13:08 +0200
commit5acd3b7460ed72b77d2757695f4c7270ce725334 (patch)
treeb226dfc76dbbbe767f13c4e400e34461c16ab2ed
parentsci-mathematics/coq: Stable for amd64. Retroactively mark stable for the rema... (diff)
downloadgentoo-5acd3b74.tar.gz
gentoo-5acd3b74.tar.bz2
gentoo-5acd3b74.zip
sys-libs/libieee1284: Convert to python-single-r1, EAPI 6
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild
new file mode 100644
index 000000000000..e0bf541cc76b
--- /dev/null
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 multilib-minimal
+
+DESCRIPTION="Library to query devices using IEEE1284"
+HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python static-libs"
+
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r9
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-sgml-utils
+ >=app-text/docbook-sgml-dtd-4.1
+ app-text/docbook-dsssl-stylesheets
+ dev-perl/XML-RegExp
+ )"
+
+DOCS="AUTHORS NEWS README* TODO doc/interface*"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ local myconf="--without-python"
+ multilib_is_native_abi && myconf="$(use_with python)"
+
+ ECONF_SOURCE="${S}" econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}