summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 14:02:18 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 14:02:29 -0700
commit5ada30758282bd5e2c25d52d8f9b691e4543e006 (patch)
treea33fd0672ef7be7e4dc345fe64bf14981003954f
parentdev-python/ioflo-1.7.8: Version bump (diff)
downloadgentoo-5ada3075.tar.gz
gentoo-5ada3075.tar.bz2
gentoo-5ada3075.zip
dev-python/ioflo-2.0.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/ioflo/Manifest1
-rw-r--r--dev-python/ioflo/ioflo-2.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ioflo/Manifest b/dev-python/ioflo/Manifest
index c191ce0d46f6..cf6bfe097391 100644
--- a/dev-python/ioflo/Manifest
+++ b/dev-python/ioflo/Manifest
@@ -1,2 +1,3 @@
DIST ioflo-1.7.5.tar.gz 838342 BLAKE2B 2eff6af7586400ff562999679b861079184757c951e006d2f300ec894dd17fa9c2ed975781109f6d3bd2cabf0e038ccf81d9f9aeac742313eedaabb59b5a1c82 SHA512 886767d72c4067727d47652fba157a76ecd8a6a5478a761feb3923992ffc585addfe892027ade104c5d44a56fd1645c0548ce3b554553f58e1104864c359470b
DIST ioflo-1.7.8.tar.gz 838925 BLAKE2B 2df2635990292c416cd4dc3bed5efedce29e494e2488ef5d23294e06ccaaa7f148fd5115ada0fb19dedfc090038ace48027d0bd9eb84a2e2c2c2be223ef2e4eb SHA512 eb6c8e28b915860184beef80281c6d0b0ade851a0d5727005abeca48ee23ba6711de2e1733d2d83d195eb88c0382a626cd7f8e3b5d24d4162409d1d67b225c95
+DIST ioflo-2.0.0.tar.gz 838200 BLAKE2B 876a38df5e6fb953eef6e65bb793fa975a4fed8d4f698029e26747a4887a449bcf5cc5c9fcce081f9b93faeb34d0f783b2f81e17ec619d7ca95810762eae810d SHA512 b4b70aef65cffe067d7563682a2cbeac0a07cd4722aa2de8fb56fd127c99df771dc5d3d22be24aadd628a26fd1b7407db684ea7257b45eba8f8376f4ad226a87
diff --git a/dev-python/ioflo/ioflo-2.0.0.ebuild b/dev-python/ioflo/ioflo-2.0.0.ebuild
new file mode 100644
index 000000000000..f572567710fd
--- /dev/null
+++ b/dev-python/ioflo/ioflo-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7,8})
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-lang/python-3.7.4' python3_7)
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/ioflo-1.7.8-network-test.patch"
+)
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's:"setuptools_git[^"]*",::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}