summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-21 20:59:35 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-21 17:03:59 -0400
commit5ae1078a706628247d4a35451d61c325fa123c4f (patch)
tree8059e6676dd4597d89a83278d003f9e3206a63ee
parentapp-i18n/fcitx-configtool: Specify slot in dependency on app-i18n/fcitx. (diff)
downloadgentoo-5ae1078a706628247d4a35451d61c325fa123c4f.tar.gz
gentoo-5ae1078a706628247d4a35451d61c325fa123c4f.tar.bz2
gentoo-5ae1078a706628247d4a35451d61c325fa123c4f.zip
app-i18n/fcitx-configtool: Version bump (0.4.10).
-rw-r--r--app-i18n/fcitx-configtool/Manifest1
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/Manifest b/app-i18n/fcitx-configtool/Manifest
index a268576b60c0..34fce1a3e93e 100644
--- a/app-i18n/fcitx-configtool/Manifest
+++ b/app-i18n/fcitx-configtool/Manifest
@@ -1,3 +1,4 @@
+DIST fcitx-configtool-0.4.10.tar.xz 50440 SHA256 bcc4976976bfbddbfec3f689f38927fbabc7f7fa611ea252a789583ea14cd1fb SHA512 1c1267e9de694bbd5f258b5bba1e7514c4f8556cdc82a1cce5eafd8a4ec571955285dade0acd02f128eca01f867a30c5c6264ee7e91d32a333eba6e4d275fe8f WHIRLPOOL bbbc2a5c9d2247312b00c75a2469ec11f2992d8ca9d5b6bc7fec7b395973dd64fb3c7aed796682ea2a819f227daddb371a565cbedab7ba2b08838a74051c8417
DIST fcitx-configtool-0.4.6.tar.xz 41992 SHA256 8d64107f9f12b4f2cbd82e40b87a2dc4dc76d0ff854481c1103d5e9a2c2e129d SHA512 946bceb77fc6d14210154d9264c86d3333f910893cf3054f65eab72641421847e8ac003889b742f4c28f74c8ab1cfbcfb82abe35ea83ca2548cfc1decc92fc4c WHIRLPOOL 58f8a420f6c98cb6d710bd05d8ca2a3ca48a115015e6de98b105bf71b59bf3dab34eb63009d763dc7a3554fa6ec0b442e8bb277f890230dd94ec371397a6766c
DIST fcitx-configtool-0.4.8.tar.xz 47196 SHA256 0ebc06d9d325fed096e9cb61fe53b82000d2de0e9aefe5945ba8f0aa2ca851ed SHA512 7b3c43b9d7d1dab04880effe6fc4e80e64c9bad34699c0c8d2992ec971605ef2eaa0b1fb13f71a582289c75560c3edc95af21f6413ac2bb594d5cdb31a0b4cb7 WHIRLPOOL a1817bcc9d6bdcd96e66dbe71d44cb66d6b66802e366b8f21d5f922495176463fc23adff2bbdbfb4003ddcef43839fab06715231fdaada8714eec1e3a073f18f
DIST fcitx-configtool-0.4.9.tar.xz 48796 SHA256 592075d28224f8ce5304281c507ab2f9a9dd93f118eeec30d442ff3db214f9fa SHA512 800c731b370ace833179560260df7ffc9c0235c4f3257e8a99a0194f2fd06b71f738e6c77985871c3368179f944da2165dac5d4a8f7ba083519cb2509a9eb62b WHIRLPOOL ae5157178cbaedd66512da6548e79b0a09dd11e4ce8797ae3387c698cd33b51facf1153dca0d3e16cbf77a01959d01251a5dcd7fb6b30f119807d56a2a0f8470
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
new file mode 100644
index 000000000000..28b6f212a5c3
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-configtool"
+fi
+
+DESCRIPTION="GTK+ GUI configuration tool for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-configtool"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2=OFF
+ -DENABLE_GTK3=ON
+ )
+
+ cmake-utils_src_configure
+}