summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-09 23:22:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-09 23:34:38 +0200
commit5b09b9c76aad244071b118857a3306f983dbcf37 (patch)
tree917b9f945b6499dec057d3e68705468cfa79d7ab
parentdev-perl/Gearman: Remove old versions re bug #613710 (diff)
downloadgentoo-5b09b9c7.tar.gz
gentoo-5b09b9c7.tar.bz2
gentoo-5b09b9c7.zip
sci-geosciences/qgis: Fix USE=python
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-geosciences/qgis/files/qgis-2.18.6-python.patch25
-rw-r--r--sci-geosciences/qgis/qgis-2.18.6.ebuild5
2 files changed, 29 insertions, 1 deletions
diff --git a/sci-geosciences/qgis/files/qgis-2.18.6-python.patch b/sci-geosciences/qgis/files/qgis-2.18.6-python.patch
new file mode 100644
index 000000000000..b8a812d3e4fa
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-2.18.6-python.patch
@@ -0,0 +1,25 @@
+commit 13d8e30bbe0ee17fff32a3eba90cd217d277e5ac
+Author: Marco Bernasocchi <marco@opengis.ch>
+Date: Wed Dec 7 19:08:24 2016 +1300
+
+ fix 2.18 build with Qt5 by executing pyuic
+
+diff --git a/scripts/pyuic-wrapper.sh b/scripts/pyuic-wrapper.sh
+index d6fb497a84..aa146b31bb 100755
+--- a/scripts/pyuic-wrapper.sh
++++ b/scripts/pyuic-wrapper.sh
+@@ -15,12 +15,12 @@
+ ###########################################################################
+
+
+-PYUIC4=$1
++PYUIC=$1
+ LD_LIBRARY_PATH=$2:$LD_LIBRARY_PATH
+ PYTHONPATH=$3:$PYTHONPATH
+ PYTHON=$4
+ shift 4
+
+ export LD_LIBRARY_PATH PYTHONPATH
+-
++$PYUIC $@
+ exec $PYTHON $(dirname $0)/pyuic-wrapper.py $@
diff --git a/sci-geosciences/qgis/qgis-2.18.6.ebuild b/sci-geosciences/qgis/qgis-2.18.6.ebuild
index 42c6a19e4aa3..53dee9ff00ee 100644
--- a/sci-geosciences/qgis/qgis-2.18.6.ebuild
+++ b/sci-geosciences/qgis/qgis-2.18.6.ebuild
@@ -90,7 +90,10 @@ RDEPEND="${COMMON_DEPEND}
# Disabling test suite because upstream disallow running from install path
RESTRICT="test"
-PATCHES=( "${FILESDIR}/${P}-featuresummary.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-featuresummary.patch"
+ "${FILESDIR}/${P}-python.patch"
+)
pkg_setup() {
use python && python-single-r1_pkg_setup