summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-23 13:49:32 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-23 15:13:16 +0200
commit5b0e0501a33ac698c992d4593654cdd12da09675 (patch)
tree42f1c95cd13be5e3146db95990e4df2671428c50
parentdev-python/capturer: Add python3.5 support (diff)
downloadgentoo-5b0e0501a33ac698c992d4593654cdd12da09675.tar.gz
gentoo-5b0e0501a33ac698c992d4593654cdd12da09675.tar.bz2
gentoo-5b0e0501a33ac698c992d4593654cdd12da09675.zip
dev-python/humanfriendly: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/humanfriendly/Manifest1
-rw-r--r--dev-python/humanfriendly/humanfriendly-1.42.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 46bdc261459e..7d48d91517a3 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,3 +1,4 @@
DIST humanfriendly-1.33.tar.gz 34362 SHA256 158259d5cb9b762fb094a3cbbade70b5e623568b92c3765d1914fa87f5bf4ecc SHA512 878dc081b15df2f1d682697b9abde45ea20aebd4a33bd7079af7eb3c86b331ad2135b7153b6727ddadbc2146fe042d5a860aaab4889a637622636d4118179bf5 WHIRLPOOL c57a7404341cff1eca80069e35350b99ddf3c26b68894ab283d39ad4dd80fbd2014f04a8dfdb040aae432c4b2ed9bdc51f0085d743575c78eddcc9985cf3cbed
DIST humanfriendly-1.35.tar.gz 36181 SHA256 de030bb1976b526f514c9a953c38286f50c3ece01180a1efdda56f091eb33164 SHA512 3cec8629423f640b2b6bdcf95aa8346daf88268b3d7e9ce44be395f7e9f3aa1a23d27d422db3bfda32e1e6c2c6a2eaf8dc1393ef6fcea4895ef6b44671353d0d WHIRLPOOL c44a897a81b2044a9d6913fb1d74d6979534d00cce486035b23facbc5595532996cb19c8b34cd7768381e67ff277b6ed02c034341958f4eff63940136cecaf27
DIST humanfriendly-1.38.tar.gz 41228 SHA256 1706a6e72c28d4001d2f2c963e74d120d36b9b9047e4026c0909f37b3da5e558 SHA512 2409e00ab9a50537a9ef03216a1e3e31f503a879afdf1b642a63f68e0a839a58d90610548f5ba2db57d32ec8e7106ab160e64b212053dfbbedca00128c1f6fdc WHIRLPOOL 8d2a98dbd08381870464b0e1ff4817b34ec0ac85b321e6cf460bfded0047976c3639898bd5d3811f859fed40f368085be561dc2f61a720deb586a21c181f2398
+DIST humanfriendly-1.42.tar.gz 42222 SHA256 e64417fd2b7e9b1fa0c2264e03a289734c2c7692030059fc4d3a0440b1e87da3 SHA512 464209a84020c799282271bedd23b08c198f77cfe0e1f6175bec4d2b946a024d5fc4d550f5d79c76492f30b73a105484a84faaea4f6602905e289dc5ae5a19c0 WHIRLPOOL 50fdc7166be36df430f626fe4ba6024e2158f5a1345e3b82086e46adb4b78ca5ac861719a6c139d30096c09651f7173176a63d776f60a9cceb86badcfd9781a3
diff --git a/dev-python/humanfriendly/humanfriendly-1.42.ebuild b/dev-python/humanfriendly/humanfriendly-1.42.ebuild
new file mode 100644
index 000000000000..45f072a1def3
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-1.42.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.python.org/pypi/humanfriendly https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ )
+ "
+python_test() {
+ esetup.py test
+}