summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-08 12:08:49 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-08 12:08:59 +0100
commit5b2429b9df43dd5e22310de79f9d5b0c1efd31af (patch)
tree007567c142fa5d742bfdca4bab7c4c411175ec6c
parentnet-misc/youtube-dl: Version 2019.02.08 (diff)
downloadgentoo-5b2429b9.tar.gz
gentoo-5b2429b9.tar.bz2
gentoo-5b2429b9.zip
net-analyzer/iftop: Version 9999999
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild16
-rw-r--r--net-analyzer/iftop/iftop-9999999.ebuild43
2 files changed, 51 insertions, 8 deletions
diff --git a/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
index 890ba6ff2aeb..ba3c20d34201 100644
--- a/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
+++ b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils
+EAPI=7
+inherit autotools
DESCRIPTION="display bandwidth usage on an interface"
SRC_URI="http://www.ex-parrot.com/pdw/iftop/download/${P/_/}.tar.gz"
@@ -20,14 +20,14 @@ DEPEND="
${RDEPEND}
virtual/pkgconfig
"
-S="${WORKDIR}"/${P/_/}
PATCHES=(
- "${FILESDIR}"/${P}-configure.ac.patch
- "${FILESDIR}"/${P}-Makefile.am.patch
- "${FILESDIR}"/${P}-tsent-set-but-not-used.patch
- "${FILESDIR}"/${P}-ip6.arpa.patch
- "${FILESDIR}"/${P}-fix-MAC-formatting.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-configure.ac.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-Makefile.am.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-tsent-set-but-not-used.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-ip6.arpa.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-fix-MAC-formatting.patch
)
+S="${WORKDIR}"/${P/_/}
src_prepare() {
default
diff --git a/net-analyzer/iftop/iftop-9999999.ebuild b/net-analyzer/iftop/iftop-9999999.ebuild
new file mode 100644
index 000000000000..5e2de84db474
--- /dev/null
+++ b/net-analyzer/iftop/iftop-9999999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="display bandwidth usage on an interface"
+HOMEPAGE="http://www.ex-parrot.com/pdw/iftop/"
+EGIT_REPO_URI="https://code.blinkace.com/pdw/iftop"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+S="${WORKDIR}"/${P/_/}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0_pre4-configure.ac.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-Makefile.am.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-fix-MAC-formatting.patch
+)
+
+src_prepare() {
+ default
+ # bug 490168
+ cat "${FILESDIR}"/ax_pthread.m4 >> "${S}"/acinclude.m4 || die
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin iftop
+ doman iftop.8
+
+ dodoc AUTHORS ChangeLog README "${FILESDIR}"/iftoprc
+}