summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin Tokarev <annulen@yandex.ru>2021-11-29 05:25:07 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-11-30 09:27:44 +0200
commit5b3de10a4a7d5f1819c5401d6a00ea25a0916be2 (patch)
treecd2b9bf756b5573aae5203688e251d07febf9343
parentdev-cpp/notcurses: remove 2.4.5 (diff)
downloadgentoo-5b3de10a.tar.gz
gentoo-5b3de10a.tar.bz2
gentoo-5b3de10a.zip
sys-devel/dwz: Version update to 0.14
Closes: https://bugs.gentoo.org/808234 Signed-off-by: Konstantin Tokarev <annulen@yandex.ru> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-devel/dwz/Manifest1
-rw-r--r--sys-devel/dwz/dwz-0.14.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/dwz/Manifest b/sys-devel/dwz/Manifest
index e03a7ec5d0f8..218f3233c2f9 100644
--- a/sys-devel/dwz/Manifest
+++ b/sys-devel/dwz/Manifest
@@ -1 +1,2 @@
DIST dwz-0.13.tar.xz 114016 BLAKE2B 0e53bb99a7790dbdd724594ad00f76267483fe31bf99c9a6ea67f8ca031d2559d5cfc79f613c81b1a99f9086aa16570cb4d850f36ddbc60bdec443dc3122cae7 SHA512 8dc5e647a99ab652fbbed2d37c595a072a2e31198e66f84220d4caf04a9ee0b2900b116932f268b68015e4cc6b49b87313bf1a2d00748d2b3c4799c9ee58c2f4
+DIST dwz-0.14.tar.xz 147428 BLAKE2B 286350a8276a1a674937a7adc99560562782044fd6caa50c9a55ec08343f34d8bd27140cca904e648859aba61d181e01ab0755f2115151fab16d498aa1549450 SHA512 62c39f79723ca99305dbb08d1d24a17699b9a84dd98c30904103da116831b1253bf1edbfb905c76fdc4d48305bd1ea0046314c5619209c40a1e624b8ae4908b1
diff --git a/sys-devel/dwz/dwz-0.14.ebuild b/sys-devel/dwz/dwz-0.14.ebuild
new file mode 100644
index 000000000000..2980b142e30d
--- /dev/null
+++ b/sys-devel/dwz/dwz-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="DWARF optimization and duplicate removal tool"
+HOMEPAGE="https://sourceware.org/dwz"
+SRC_URI="https://sourceware.org/ftp/dwz/releases/${P}.tar.xz"
+
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/elfutils"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-util/dejagnu
+ dev-libs/elfutils[utils]
+)"
+
+src_prepare() {
+ default
+ sed -e '/^CFLAGS/d' -i Makefile || die
+ tc-export CC
+}