summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-11-25 13:53:43 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-11-29 09:12:52 +0200
commit5b4784f1cf002fdf57a513856656fb47651ff044 (patch)
tree9810108cd73290f2080ffe023016c95057ffed47
parentsys-fs/genfstab: update maintainers - drop p-m (diff)
downloadgentoo-5b4784f1cf002fdf57a513856656fb47651ff044.tar.gz
gentoo-5b4784f1cf002fdf57a513856656fb47651ff044.tar.bz2
gentoo-5b4784f1cf002fdf57a513856656fb47651ff044.zip
x11-misc/slop: bump to 7.6
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Closes: https://github.com/gentoo/gentoo/pull/23077 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-misc/slop/Manifest1
-rw-r--r--x11-misc/slop/slop-7.6.ebuild (renamed from x11-misc/slop/slop-9999.ebuild)27
2 files changed, 14 insertions, 14 deletions
diff --git a/x11-misc/slop/Manifest b/x11-misc/slop/Manifest
index 58b030f80488..4dace195982a 100644
--- a/x11-misc/slop/Manifest
+++ b/x11-misc/slop/Manifest
@@ -1 +1,2 @@
DIST slop-7.5.tar.gz 51060 BLAKE2B 8d0fcf932181dfc482be7c54cf5a08605a32c85bcd8b27223a4cd8a08323382e802a7f20faa6c51fe67583b1d320cf783c7b5cc8b871e534ea11a32b827e1f45 SHA512 c02e40c5b924841996617fcc9629a6a739a04b6128c18e1eb06dc285d2f8026d847e67077fb59a111fc45c112f871a6e5faef20108c3d777271e1d4aca7f4737
+DIST slop-7.6.tar.gz 198605 BLAKE2B fcf8b0e1212f50044aa3e3a15d208ee3fda9e1883b9601beba6b29ad574555db83f382547bbe064570765e1ed1e7c0c92bf891edadf89f006bfdf10a5b469c66 SHA512 d1abc50cad124cfb11e9b57c38c824efb2ece3dffce8e54e451ce4adc4a7ad441c6171b7df5d1c8dfa66c875a12cf07b206ba3b87229c0e5f2ddf744d7922fc3
diff --git a/x11-misc/slop/slop-9999.ebuild b/x11-misc/slop/slop-7.6.ebuild
index a9c376b256ec..849d37f0f0aa 100644
--- a/x11-misc/slop/slop-9999.ebuild
+++ b/x11-misc/slop/slop-7.6.ebuild
@@ -1,20 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
DESCRIPTION="Application that queries the user for a selection for printing"
HOMEPAGE="https://github.com/naelstrof/slop"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
-else
- SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
LICENSE="GPL-3"
SLOT="0/${PV}"
@@ -31,13 +25,18 @@ RDEPEND="
x11-libs/libXrender:=
)
"
-DEPEND="${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+DEPEND="
+ ${RDEPEND}
media-libs/glm
"
+PATCHES=( "${FILESDIR}/${PN}"-7.5-missing-header.patch )
+
src_configure() {
- local mycmakeargs=(
- -DSLOP_OPENGL=$(usex opengl)
- )
+ local mycmakeargs=( -DSLOP_OPENGL=$(usex opengl) )
cmake_src_configure
}