summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-20 13:51:06 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-20 14:52:14 +0100
commit5b4cac8fb49eb9c4bb3cff2a716ffcac673f4865 (patch)
tree792ba08eaa2491c3b0638b01da065e9eaade2e3c
parentmail-client/evolution: Drop old (diff)
downloadgentoo-5b4cac8fb49eb9c4bb3cff2a716ffcac673f4865.tar.gz
gentoo-5b4cac8fb49eb9c4bb3cff2a716ffcac673f4865.tar.bz2
gentoo-5b4cac8fb49eb9c4bb3cff2a716ffcac673f4865.zip
mail-client/evolution: Version bump
Package-Manager: portage-2.2.27
-rw-r--r--mail-client/evolution/Manifest1
-rw-r--r--mail-client/evolution/evolution-3.18.5.1.ebuild150
2 files changed, 151 insertions, 0 deletions
diff --git a/mail-client/evolution/Manifest b/mail-client/evolution/Manifest
index e3b7c49c8655..a5ae2ed42946 100644
--- a/mail-client/evolution/Manifest
+++ b/mail-client/evolution/Manifest
@@ -1,2 +1,3 @@
DIST evolution-3.16.5.tar.xz 11962476 SHA256 fef4e8d0a81dc4562f984dddc5ccfee885506a2e030692b5ac6cd50e32efce37 SHA512 6f99982c42d462cc449eb8c56e22cde1ff628111b52e12fd6c8cbcbf86dbc047431aea2507c7026589bfe54b020443f3a647190de72cc235ce45f72f8d55b222 WHIRLPOOL 462e71bd51a0d5be9d5f6d9f965ae3121612ebd56066de43d328dd003cd61ab155af0c48b58868bf220e6956eee01844cbe923ea64fb30a9b88ba10d1e4c74e3
DIST evolution-3.18.4.tar.xz 12062432 SHA256 8161a0ebc77e61904dfaca9745595fefbf84d834a07ee1132d1f8d030dabfefb SHA512 ddb7922cedd490808c21a21d6a2e23f7399f1569bea69d5e0434f27b0f5b75b898ff68f17883bfd75eddb2ec9059628406e1b1f7811e1962a6da2dff4777ade2 WHIRLPOOL 3f2be015121e5fa2114b47dc07c3453370d8028080d36d202b323b2ddafe29a4eeab43840a2278ceb06ec313ed5cffd7cc602ab47eafb7d4e93fbfe4f7cb87e8
+DIST evolution-3.18.5.1.tar.xz 12067580 SHA256 20e5acd345107fdfe19ac28cd1ea4252014f28428a59d273890944c415f0590b SHA512 d2e3468cf4cdfa76c3ca6fb0816938e1a40bdcccbe2e161750a021fd9e0b0dab758574f4ac07a46a460e3ae5dbd4ddfc842b04e8cc27e120888efbcbd72fa16a WHIRLPOOL d73f3dbbe4b5460efdb3da461d8217bc18c50cc8f414ebf016c27c86d4585c3f8a42716a77ebf3499305278b572ed8cb18f82f19b848398c2df6c7e57f5760e4
diff --git a/mail-client/evolution/evolution-3.18.5.1.ebuild b/mail-client/evolution/evolution-3.18.5.1.ebuild
new file mode 100644
index 000000000000..dedc34aa55a9
--- /dev/null
+++ b/mail-client/evolution/evolution-3.18.5.1.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils flag-o-matic readme.gentoo-r1 gnome2
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP"
+SLOT="2.0"
+
+IUSE="+bogofilter crypt highlight ldap map spamassassin spell ssl +weather"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# We need a graphical pinentry frontend to be able to ask for the GPG
+# password from inside evolution, bug 160302
+PINENTRY_DEPEND="|| ( app-crypt/pinentry[gnome-keyring] app-crypt/pinentry[gtk] app-crypt/pinentry[qt4] )"
+
+# glade-3 support is for maintainers only per configure.ac
+# pst is not mature enough and changes API/ABI frequently
+# dconf explicitely needed for backup plugin
+# gnome-desktop support is optional with --enable-gnome-desktop
+# gnome-autoar (currently disabled because no release has been made)
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.4
+ >=app-text/enchant-1.1.7
+ >=dev-libs/glib-2.40:2[dbus]
+ >=dev-libs/libxml2-2.7.3:2
+ >=gnome-base/gnome-desktop-2.91.3:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=gnome-extra/evolution-data-server-3.18.2:=[gtk,weather?]
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/libsoup-2.42:2.4
+ >=net-libs/webkit-gtk-2.2:3
+ >=x11-libs/cairo-1.9.15:=[glib]
+ >=x11-libs/gdk-pixbuf-2.24:2
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/libnotify-0.7:=
+ >=x11-misc/shared-mime-info-0.22
+
+ >=app-text/iso-codes-0.49
+ dev-libs/atk
+ gnome-base/dconf
+ dev-libs/libical:=
+ x11-libs/libSM
+ x11-libs/libICE
+
+ crypt? (
+ >=app-crypt/gnupg-1.4
+ ${PINENTRY_DEPEND}
+ x11-libs/libcryptui )
+ map? (
+ >=media-libs/libchamplain-0.12:0.12[gtk]
+ >=media-libs/clutter-1.0.0:1.0
+ >=media-libs/clutter-gtk-0.90:1.0
+ >=sci-geosciences/geocode-glib-3.10.0
+ x11-libs/mx:1.0 )
+ spell? ( app-text/gtkspell:3 )
+ ldap? ( >=net-nds/openldap-2:= )
+ ssl? (
+ >=dev-libs/nspr-4.6.1:=
+ >=dev-libs/nss-3.11:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# app-text/yelp-tools
+# >=gnome-base/gnome-common-2.12
+RDEPEND="${COMMON_DEPEND}
+ bogofilter? ( mail-filter/bogofilter )
+ highlight? ( app-text/highlight )
+ spamassassin? ( mail-filter/spamassassin )
+ !gnome-extra/evolution-exchange
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="To change the default browser if you are not using GNOME, edit
+~/.local/share/applications/mimeapps.list so it includes the
+following content:
+
+[Default Applications]
+x-scheme-handler/http=firefox.desktop
+x-scheme-handler/https=firefox.desktop
+
+(replace firefox.desktop with the name of the appropriate .desktop
+file from /usr/share/applications if you use a different browser)."
+
+src_prepare() {
+ # Fix relink issues in src_install
+ ELTCONF="--reverse-deps"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ gnome2_src_configure \
+ --without-glade-catalog \
+ --disable-autoar \
+ --disable-code-coverage \
+ --disable-installed-tests \
+ --disable-pst-import \
+ --enable-canberra \
+ $(use_enable crypt libcryptui) \
+ $(use_enable highlight text-highlight) \
+ $(use_enable map contact-maps) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_with bogofilter) \
+ $(use_with ldap openldap) \
+ $(use_with spamassassin) \
+ $(usex ssl --enable-nss=yes "--without-nspr-libs
+ --without-nspr-includes
+ --without-nss-libs
+ --without-nss-includes") \
+ $(use_enable weather)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS* README"
+
+ gnome2_src_install
+
+ # Problems with prelink:
+ # https://bugzilla.gnome.org/show_bug.cgi?id=731680
+ # https://bugzilla.gnome.org/show_bug.cgi?id=732148
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1114538
+ echo PRELINK_PATH_MASK=/usr/bin/evolution > ${T}/99${PN}
+ doenvd "${T}"/99${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}