summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-12-28 15:28:33 -0800
committerZac Medico <zmedico@gentoo.org>2020-12-28 15:28:33 -0800
commit5b4dd2b3692c0d6d0b4d62c19110414b841b0b09 (patch)
tree63805bbc2bb882de2418d1df31457d025751736b
parentapp-emulation/slirp4netns: Bump to version 1.1.8 (diff)
downloadgentoo-5b4dd2b3.tar.gz
gentoo-5b4dd2b3.tar.bz2
gentoo-5b4dd2b3.zip
app-emulation/conmon: Bump to version 2.0.22
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/conmon/Manifest1
-rw-r--r--app-emulation/conmon/conmon-2.0.22.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/conmon/Manifest b/app-emulation/conmon/Manifest
index 15b98a0d987f..b88f13d27b26 100644
--- a/app-emulation/conmon/Manifest
+++ b/app-emulation/conmon/Manifest
@@ -1 +1,2 @@
DIST conmon-2.0.20.tar.gz 64716 BLAKE2B d7eb464f5be0b117824571134f08077955f56e1637dd2cbc6b70413dc9a6f109a1b9b207f5523103f205659ac20cc65f5f2340475d771fdf4b852d6895887975 SHA512 b719e41e1ead0d38c0874a30901c5660dc8612dc7aa1c025068480846a1e458a744b55bb8d5d74d2c2ce38fdbbe03505fce216a2f2c0748740983e3272a82f0e
+DIST conmon-2.0.22.tar.gz 103371 BLAKE2B f509ba800c847886ec2350e141d2b965ff1cc09822467718fb0d94acdabdc86c6f40dff9428679e4c4171ac6a522b3ba7622d66ebd8108be1a68cbf7418d5c09 SHA512 819e1d9279c1a22388220d710b975cdeb3c0b56413afb177afe1c96b649e2dce496d5f51fe4094f572111f771102ccd0ae86f1776e99fedb2e76e6e9130c2d5c
diff --git a/app-emulation/conmon/conmon-2.0.22.ebuild b/app-emulation/conmon/conmon-2.0.22.ebuild
new file mode 100644
index 000000000000..967a5d5432eb
--- /dev/null
+++ b/app-emulation/conmon/conmon-2.0.22.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="9c34a8663b85e479e0c083801e89a2b2835228ed"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+SRC_URI="https://github.com/containers/conmon/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="systemd"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| $(PKG_CONFIG) --exists libsystemd-journal | false |' \
+ -e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}