summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:55:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 06:06:43 +0100
commit5b54d5167a805660b505c95084b85eda453fd0c8 (patch)
treef835f996708b61a7cb56a88e0000aa1c3e9c2469
parentdev-python/natsort: Bump to 8.3.0 (diff)
downloadgentoo-5b54d516.tar.gz
gentoo-5b54d516.tar.bz2
gentoo-5b54d516.zip
dev-python/pooch: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pooch/Manifest1
-rw-r--r--dev-python/pooch/pooch-1.7.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index ee30b77b2b53..8f1544872239 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1 +1,2 @@
DIST pooch-1.6.0.tar.gz 52318 BLAKE2B c5cdf04a27a5754accee5a4522d5e6a51c4e71b7034cd570c6a2f30bc580ba9c15e0717be792e7cdd020ca745e6813a63681ce966ad61c0ed4aaa8b84829b920 SHA512 e1b6253b8879ef172bd6370139a7807355c7e1c03a1626ac46cb083b1f7d8beb5a8adb08c0828eb34e96a7164211d2dc7da214fd0176eb0606fe4ff47911257c
+DIST pooch-1.7.0.tar.gz 57457 BLAKE2B d85fc3cc707bfa639f46bf75b89dd31714f7a4f64a90ff7a6c92b792a8209e66a5fffb62912a336cd481330c37c0037df116d27ea06808bf02f1039e2aac930b SHA512 60126b893a9a1422aad12349143fbe72e485004f79b06da752f51ae374f375efae693304210c8d62b211433d7ce75fab53a50a6f267b1952df83fdccc2de13a7
diff --git a/dev-python/pooch/pooch-1.7.0.ebuild b/dev-python/pooch/pooch-1.7.0.ebuild
new file mode 100644
index 000000000000..2cc8a7f0a32f
--- /dev/null
+++ b/dev-python/pooch/pooch-1.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="
+ https://github.com/fatiando/pooch/
+ https://pypi.org/project/pooch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ pooch/tests/test_core.py::test_check_availability_invalid_downloader
+ pooch/tests/test_core.py::test_load_registry_from_doi
+ pooch/tests/test_core.py::test_load_registry_from_doi_zenodo_with_slash
+ pooch/tests/test_downloaders.py::test_invalid_doi_repository
+ pooch/tests/test_downloaders.py::test_doi_url_not_found
+ pooch/tests/test_downloaders.py::test_figshare_url_file_not_found
+ pooch/tests/test_downloaders.py::test_doi_downloader
+)
+
+### docs no included in pypi tarball
+# distutils_enable_sphinx doc \
+# dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -k "not network"
+}