summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-15 00:50:39 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-19 14:38:00 +0100
commit5b56b99eeb7c29df23e317f9f3627ac7aa2eeb18 (patch)
tree15bc3b3c4f554573e60a5b4cc604d714a8298883
parentnet-fs/samba: Security cleanup (bug #578004). (diff)
downloadgentoo-5b56b99e.tar.gz
gentoo-5b56b99e.tar.bz2
gentoo-5b56b99e.zip
media-video/vlc: Fix build with libav-11.7
Gentoo-bug: 593460 Sync more changes from release -> live ebuilds Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3122
-rw-r--r--media-video/vlc/files/vlc-2.2.4-libav-11.7.patch10
-rw-r--r--media-video/vlc/vlc-2.2.9999.ebuild28
-rw-r--r--media-video/vlc/vlc-9999.ebuild28
3 files changed, 44 insertions, 22 deletions
diff --git a/media-video/vlc/files/vlc-2.2.4-libav-11.7.patch b/media-video/vlc/files/vlc-2.2.4-libav-11.7.patch
new file mode 100644
index 000000000000..932223632d73
--- /dev/null
+++ b/media-video/vlc/files/vlc-2.2.4-libav-11.7.patch
@@ -0,0 +1,10 @@
+--- a/modules/codec/avcodec/audio.c 2016-09-10 13:46:51.066453337 -0700
++++ a/modules/codec/avcodec/audio.c 2016-09-10 13:42:26.061451090 -0700
+@@ -38,6 +38,7 @@
+
+ #include <libavcodec/avcodec.h>
+ #include <libavutil/mem.h>
++#include <libavutil/channel_layout.h>
+
+ #include "avcodec.h"
+
diff --git a/media-video/vlc/vlc-2.2.9999.ebuild b/media-video/vlc/vlc-2.2.9999.ebuild
index 8c5988fb3b3f..fec5c5232019 100644
--- a/media-video/vlc/vlc-2.2.9999.ebuild
+++ b/media-video/vlc/vlc-2.2.9999.ebuild
@@ -5,7 +5,7 @@
EAPI=6
SCM=""
-if [ "${PV%9999}" != "${PV}" ] ; then
+if [[ ${PV} = *9999 ]] ; then
SCM="git-r3"
if [ "${PV%.9999}" != "${PV}" ] ; then
@@ -23,7 +23,7 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="VLC media player - Video player and streamer"
HOMEPAGE="http://www.videolan.org/vlc/"
-if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+if [[ ${PV} = *9999 ]] ; then # Live ebuild
SRC_URI=""
elif [[ "${MY_P}" == "${P}" ]]; then
SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
@@ -47,10 +47,10 @@ IUSE="a52 aalib alsa altivec atmo +audioqueue +avcodec
macosx-dialog-provider macosx-eyetv macosx-quartztext macosx-qtkit
matroska cpu_flags_x86_mmx modplug mp3 mpeg
mtp musepack ncurses neon ogg omxil opencv opengl optimisememory opus
- png +postproc projectm pulseaudio +qt4 qt5 rdp rtsp run-as-root samba
+ png postproc projectm pulseaudio +qt4 qt5 rdp rtsp run-as-root samba
schroedinger sdl sdl-image sftp shout sid skins speex cpu_flags_x86_sse svg +swscale
taglib theora tremor truetype twolame udev upnp vaapi v4l vcdx vdpau
- vlm vnc vorbis vpx wma-fixed +X x264 x265 +xcb xml xv zvbi zeroconf"
+ vlm vnc vorbis vpx wma-fixed +X x264 x265 +xcb xml xv zeroconf zvbi"
RDEPEND="
dev-libs/libgpg-error:0
@@ -123,8 +123,9 @@ RDEPEND="
pulseaudio? ( >=media-sound/pulseaudio-1:0 )
!qt5? ( qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 ) )
qt5? ( dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5 )
- rdp? ( >=net-misc/freerdp-1.0.1:0= )
- samba? ( || ( >=net-fs/samba-3.4.6:0[smbclient] >=net-fs/samba-4:0[client] ) )
+ rdp? ( =net-misc/freerdp-1*:0=[client] )
+ samba? ( || ( ( >=net-fs/samba-3.4.6:0[smbclient] <net-fs/samba-4.0.0_alpha1:0[smbclient] )
+ >=net-fs/samba-4.0.0_alpha1:0[client] ) )
schroedinger? ( >=media-libs/schroedinger-1.0.10:0 )
sdl? ( >=media-libs/libsdl-1.2.10:0
sdl-image? ( >=media-libs/sdl-image-1.2.10:0 sys-libs/zlib:0 ) )
@@ -177,9 +178,10 @@ RDEPEND="${RDEPEND}
DEPEND="${RDEPEND}
!qt5? ( kde? ( kde-base/kdelibs:4 ) )
+ amd64? ( dev-lang/yasm:* )
+ x86? ( dev-lang/yasm:* )
xcb? ( x11-proto/xproto:0 )
app-arch/xz-utils:0
- dev-lang/yasm:*
>=sys-devel/gettext-0.18.3:*
virtual/pkgconfig:*
"
@@ -190,7 +192,7 @@ REQUIRED_USE="
cddb? ( cdda )
dvb? ( dvbpsi )
dxva2? ( avcodec )
- ffmpeg? ( avcodec avformat swscale postproc )
+ ffmpeg? ( avcodec avformat swscale )
fontconfig? ( truetype )
gnutls? ( gcrypt )
httpd? ( lua )
@@ -200,8 +202,9 @@ REQUIRED_USE="
qt4? ( X )
qt5? ( X )
sdl? ( X )
- skins? ( truetype X || ( qt4 qt5 ) )
+ skins? ( truetype X xml || ( qt4 qt5 ) )
vaapi? ( avcodec X )
+ vdpau? ( xcb )
vlm? ( encode )
xv? ( xcb )
"
@@ -228,6 +231,9 @@ PATCHES=(
# Bug #594126
"${FILESDIR}"/${PN}-2.2.4-decoder-lock-scope.patch
"${FILESDIR}"/${PN}-2.2.4-alsa-large-buffers.patch
+
+ # Bug #593460
+ "${FILESDIR}"/${PN}-2.2.4-libav-11.7.patch
)
DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt doc/intf-vcd.txt )
@@ -243,7 +249,7 @@ pkg_setup() {
}
src_unpack() {
- if [ "${PV%9999}" != "${PV}" ] ; then
+ if [[ ${PV} = *9999 ]] ; then
git-r3_src_unpack
else
unpack ${A}
@@ -263,7 +269,7 @@ src_prepare() {
fi
# Bootstrap when we are on a git checkout.
- if [[ "${PV%9999}" != "${PV}" ]] ; then
+ if [[ ${PV} = *9999 ]] ; then
./bootstrap
fi
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 7b61071fcd3d..0836e19cdeea 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -5,7 +5,7 @@
EAPI=6
SCM=""
-if [ "${PV%9999}" != "${PV}" ] ; then
+if [[ ${PV} = *9999 ]] ; then
SCM="git-r3"
if [ "${PV%.9999}" != "${PV}" ] ; then
@@ -23,7 +23,7 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="VLC media player - Video player and streamer"
HOMEPAGE="http://www.videolan.org/vlc/"
-if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+if [[ ${PV} = *9999 ]] ; then # Live ebuild
SRC_URI=""
elif [[ "${MY_P}" == "${P}" ]]; then
SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
@@ -47,10 +47,10 @@ IUSE="a52 aalib alsa altivec +audioqueue +avcodec
macosx-eyetv macosx-notifications macosx-qtkit
matroska cpu_flags_x86_mmx modplug mp3 mpeg mtp musepack
ncurses neon ogg omxil opencv opengl optimisememory opus
- png +postproc projectm pulseaudio +qt4 qt5 rdp rtsp run-as-root samba
+ png postproc projectm pulseaudio +qt4 qt5 rdp rtsp run-as-root samba
schroedinger sdl sdl-image sftp shout sid skins speex cpu_flags_x86_sse svg +swscale
taglib theora tremor truetype twolame udev upnp vaapi v4l vcd vdpau
- vlm vnc vorbis vpx wma-fixed +X x264 x265 +xcb xml xv zvbi zeroconf"
+ vlm vnc vorbis vpx wma-fixed +X x264 x265 +xcb xml xv zeroconf zvbi"
RDEPEND="
dev-libs/libgpg-error:0
@@ -123,8 +123,9 @@ RDEPEND="
pulseaudio? ( >=media-sound/pulseaudio-1:0 )
!qt5? ( qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 ) )
qt5? ( dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5 )
- rdp? ( >=net-misc/freerdp-1.0.1:0= )
- samba? ( || ( >=net-fs/samba-3.4.6:0[smbclient] >=net-fs/samba-4:0[client] ) )
+ rdp? ( =net-misc/freerdp-1*:0=[client] )
+ samba? ( || ( ( >=net-fs/samba-3.4.6:0[smbclient] <net-fs/samba-4.0.0_alpha1:0[smbclient] )
+ >=net-fs/samba-4.0.0_alpha1:0[client] ) )
schroedinger? ( >=media-libs/schroedinger-1.0.10:0 )
sdl? ( >=media-libs/libsdl-1.2.10:0
sdl-image? ( >=media-libs/sdl-image-1.2.10:0 sys-libs/zlib:0 ) )
@@ -177,9 +178,10 @@ RDEPEND="${RDEPEND}
DEPEND="${RDEPEND}
!qt5? ( kde? ( kde-base/kdelibs:4 ) )
+ amd64? ( dev-lang/yasm:* )
+ x86? ( dev-lang/yasm:* )
xcb? ( x11-proto/xproto:0 )
app-arch/xz-utils:0
- dev-lang/yasm:*
>=sys-devel/gettext-0.19.6:*
virtual/pkgconfig:*
"
@@ -189,7 +191,7 @@ REQUIRED_USE="
bidi? ( truetype )
dvb? ( dvbpsi )
dxva2? ( avcodec )
- ffmpeg? ( avcodec avformat swscale postproc )
+ ffmpeg? ( avcodec avformat swscale )
fontconfig? ( truetype )
gnutls? ( gcrypt )
httpd? ( lua )
@@ -199,8 +201,9 @@ REQUIRED_USE="
qt4? ( X )
qt5? ( X )
sdl? ( X )
- skins? ( truetype X || ( qt4 qt5 ) )
+ skins? ( truetype X xml || ( qt4 qt5 ) )
vaapi? ( avcodec X )
+ vdpau? ( xcb )
vlm? ( encode )
xv? ( xcb )
"
@@ -214,6 +217,9 @@ PATCHES=(
# Fix up broken audio when skipping using a fixed reversed bisected commit.
"${FILESDIR}"/${PN}-2.1.0-TomWij-bisected-PA-broken-underflow.patch
+
+ # Bug #593460
+ "${FILESDIR}"/${PN}-2.2.4-libav-11.7.patch
)
DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
@@ -229,7 +235,7 @@ pkg_setup() {
}
src_unpack() {
- if [ "${PV%9999}" != "${PV}" ] ; then
+ if [[ ${PV} = *9999 ]] ; then
git-r3_src_unpack
else
unpack ${A}
@@ -249,7 +255,7 @@ src_prepare() {
fi
# Bootstrap when we are on a git checkout.
- if [[ "${PV%9999}" != "${PV}" ]] ; then
+ if [[ ${PV} = *9999 ]] ; then
./bootstrap
fi