summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:27:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:04 -0400
commit5b6d32c09517b79c478ab02085871717d71f86fa (patch)
tree77e076010fe1e704f5710da4981206ffaa3476c7
parentx11-misc/xsnap: pass -std=gnu89 (diff)
downloadgentoo-5b6d32c09517b79c478ab02085871717d71f86fa.tar.gz
gentoo-5b6d32c09517b79c478ab02085871717d71f86fa.tar.bz2
gentoo-5b6d32c09517b79c478ab02085871717d71f86fa.zip
x11-misc/xtoolwait: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
index f6dfa47f2340..c8cafd651d2c 100644
--- a/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
+++ b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Xtoolwait notably decreases the startup time of an X session"
HOMEPAGE="http://ftp.x.org/contrib/utilities/xtoolwait-1.3.README"
@@ -25,6 +25,8 @@ BDEPEND="
>=x11-misc/imake-1.0.8-r1"
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}