summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-01-29 09:46:18 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-01-29 09:51:26 +0100
commit5b80fa0d1307fa714376009120c445c85220fefc (patch)
tree84ce838fa50ca27c81275297efe5b585cea0369f
parentsys-libs/compiler-rt: Fix stripping -nodefaultlibs (diff)
downloadgentoo-5b80fa0d1307fa714376009120c445c85220fefc.tar.gz
gentoo-5b80fa0d1307fa714376009120c445c85220fefc.tar.bz2
gentoo-5b80fa0d1307fa714376009120c445c85220fefc.zip
mail-mta/opensmtpd: remove old and never keyworded ebuild
This is old, buggy, and we never got it working properly. Revisit this later for the 6.6 series. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--mail-mta/opensmtpd/Manifest1
-rw-r--r--mail-mta/opensmtpd/opensmtpd-6.4.0_p1.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/mail-mta/opensmtpd/Manifest b/mail-mta/opensmtpd/Manifest
index 7ade143bda40..cef24458d907 100644
--- a/mail-mta/opensmtpd/Manifest
+++ b/mail-mta/opensmtpd/Manifest
@@ -1,2 +1 @@
DIST opensmtpd-6.0.3p1.tar.gz 699702 BLAKE2B 49f08e8329adc049a562b6ef7efa4c0a39cbcfe8a158cb905cfc726a7302ffe9833ccfb52041340767d55d0f2ae2087e8eac92b7359016c6c76b4d963a334558 SHA512 e579818a0ddbe637deb5a4e40f43eaf797783903ceac18fd89a57581b135b9e407d424e1a70ff7b4b06a0ee50bafb6e8ab2451371917887904b06ff1b55d320f
-DIST opensmtpd-6.4.0p1.tar.gz 718638 BLAKE2B 23c1c286a865efcbd16461ec8930f5325a6e164a58ceb7bbe0feb9088bcf615b7fd7e2eb6820bcde161864c476087b39c289c75ea5ca0b18c46710f9723b3dd7 SHA512 c60dbac857925041769104adae33393f526a328767e19bc78d06e45a13b7dd50f3eefdaa3811b8da330c24a670e98da74e18af5ac486266dade6255a6f3b5135
diff --git a/mail-mta/opensmtpd/opensmtpd-6.4.0_p1.ebuild b/mail-mta/opensmtpd/opensmtpd-6.4.0_p1.ebuild
deleted file mode 100644
index 51dedcde092b..000000000000
--- a/mail-mta/opensmtpd/opensmtpd-6.4.0_p1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools systemd
-
-DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
-HOMEPAGE="https://www.opensmtpd.org"
-SRC_URI="https://www.opensmtpd.org/archives/${P/_}.tar.gz"
-
-LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
-SLOT="0"
-KEYWORDS="" #~amd64 ~arm ~arm64 ~x86"
-IUSE="pam +mta"
-
-DEPEND="dev-libs/libressl
- elibc_musl? ( sys-libs/fts-standalone )
- sys-libs/zlib
- pam? ( sys-libs/pam )
- sys-libs/db:=
- dev-libs/libevent
- app-misc/ca-certificates
- net-mail/mailbase
- net-libs/libasr
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp[mta]
- !mail-mta/netqmail
- !mail-mta/nullmailer
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/ssmtp[mta]
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${P/_}
-
-src_configure() {
- tc-export AR
- AR="$(which "$AR")" econf \
- --with-table-db \
- --with-user-smtpd=smtpd \
- --with-user-queue=smtpq \
- --with-group-queue=smtpq \
- --with-path-socket=/run \
- --with-path-CAfile=/etc/ssl/certs/ca-certificates.crt \
- --sysconfdir=/etc/opensmtpd \
- $(use_with pam auth-pam)
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}"/smtpd.initd smtpd
- systemd_dounit "${FILESDIR}"/smtpd.{service,socket}
- use pam && newpamd "${FILESDIR}"/smtpd.pam smtpd
- dosym /usr/sbin/smtpctl /usr/sbin/makemap
- dosym /usr/sbin/smtpctl /usr/sbin/newaliases
- if use mta ; then
- dodir /usr/sbin
- dosym /usr/sbin/smtpctl /usr/sbin/sendmail
- dosym /usr/sbin/smtpctl /usr/bin/sendmail
- dosym /usr/sbin/smtpctl /usr/$(get_libdir)/sendmail
- fi
-}
-
-pkg_preinst() {
- enewgroup smtpd 25
- enewuser smtpd 25 -1 /var/empty smtpd
- enewgroup smtpq 252
- enewuser smtpq 252 -1 /var/empty smtpq
-}
-
-pkg_postinst() {
- einfo
- einfo "Plugins for SQLite, MySQL, PostgreSQL, LDAP, socketmaps,"
- einfo "Redis, and many other useful addons and filters are"
- einfo "available in the mail-filter/opensmtpd-extras package."
- einfo
-}