summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-04 00:38:06 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-04 00:38:06 +0200
commit5b94f55c19958a617f68697de5708f3c101bd2f5 (patch)
treeb6dd4d25943bcc31bddd4e1b9e9924a543e9b26f
parentdev-perl/Text-Quoted: Add build fix for Perl 5.26, bug 623126 (diff)
downloadgentoo-5b94f55c19958a617f68697de5708f3c101bd2f5.tar.gz
gentoo-5b94f55c19958a617f68697de5708f3c101bd2f5.tar.bz2
gentoo-5b94f55c19958a617f68697de5708f3c101bd2f5.zip
dev-perl/Template-Plugin-Cycle: Add build fix for Perl 5.26, bug 623130
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
index fe309be71498..3252874f10fa 100644
--- a/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
+++ b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
@@ -1,19 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR="ADAMK"
-MODULE_VERSION="1.06"
+DIST_AUTHOR="ADAMK"
+DIST_VERSION="1.06"
inherit perl-module
DESCRIPTION="Cyclically insert into a Template from a sequence of values"
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DEPEND=">=dev-perl/Params-Util-1.60.0
- >=dev-perl/Template-Toolkit-2.240.0"
+RDEPEND="
+ >=dev-perl/Params-Util-1.60.0
+ >=dev-perl/Template-Toolkit-2.240.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}