summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:11:03 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:31:51 +0100
commit5ba9e622f61e9db7f3398d091ee343d04d1b0fe4 (patch)
treee28dac1b4e1a451a160c67d00ac2def2cc152624
parentdev-python/cffi: bump v1.13.2 (diff)
downloadgentoo-5ba9e622f61e9db7f3398d091ee343d04d1b0fe4.tar.gz
gentoo-5ba9e622f61e9db7f3398d091ee343d04d1b0fe4.tar.bz2
gentoo-5ba9e622f61e9db7f3398d091ee343d04d1b0fe4.zip
dev-php/swoole: bump to v4.4.12
Closes: https://bugs.gentoo.org/697690 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-php/swoole/Manifest1
-rw-r--r--dev-php/swoole/swoole-4.4.12.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
index cd47e4b795ff..7431340b9504 100644
--- a/dev-php/swoole/Manifest
+++ b/dev-php/swoole/Manifest
@@ -4,3 +4,4 @@ DIST swoole-4.1.1.tgz 930623 BLAKE2B fb4fa99b7b687aeaf4473983659cc2ceb7d8ba9ba6e
DIST swoole-4.2.13.tgz 1305634 BLAKE2B bb30180f7ca7b024a2aab8aff1149f6b19035315c9518dfc9e9e2e02acde09aa4cd09fbe146aefd39fc09c25af68347a5c188ca8a21677926b1adea5b549858b SHA512 f2438ce761766d20a24279a2d6f2094c718324585b1d396344f64e8a4facc1cc025a3afb2deff3b1accd5266763bdaa0a2b15e831ea4b9bdb107c83b0046636d
DIST swoole-4.2.3.tgz 1127669 BLAKE2B c99b540bf2f5c8757ae8e1b88de5db60bd2fcef0a14faebee3032419645f61c3c54c81f0ced7a4d67701bd1932d962592ea695fd4460d4d5bbb6849a2bb13674 SHA512 37758ff2c8e2638bdd9c5c7ac26ec86e71d71a75c4af0a8ac2c68c81eb74fdbb31e70489b94c50488d25ceeed1731e5f8f74316d5cce3f6e6db41623200416f1
DIST swoole-4.2.9.tgz 1220045 BLAKE2B 752d00ae6a61c0592f308fceff205be68f55eb9918288fcfa3f2ed29edaf8e3e8682a28e2c783f1eb6df097e5567690cfa88a056b1078ecbbb809e4bd81c5bb6 SHA512 5fbc7c2d5a797074ceaef89d4b5f81440bc7c911e2feda9ded4183069cc9e98bac1ab2acdc6e7788a8c7e379dc0d7b07aaa3c5374c8b20b1ea7c327bc13c87d9
+DIST swoole-4.4.12.tgz 1436554 BLAKE2B cc9e64e108aa9b393265708a6922f53824c2e9941c0f47f4f6aacf93239829381cdf4625af8f30e2ca8ceb1663047c6be8b2d7808dbc29d27100135288f7ac85 SHA512 8899bb048b85c048903c80fe1af045ea4f82a25b3b4fd9995d51c8a2ab144306f9f5651276776e3f6a29c83322fb0aeee2822d131247070fe9e2e87b26f2e0e9
diff --git a/dev-php/swoole/swoole-4.4.12.ebuild b/dev-php/swoole/swoole-4.4.12.ebuild
new file mode 100644
index 000000000000..7df45e4948c0
--- /dev/null
+++ b/dev-php/swoole/swoole-4.4.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="swoole"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests can hang. Disable until this no longer happens
+RESTRICT="test"
+
+DEPEND="
+ app-arch/brotli:0=
+ dev-libs/libaio
+ dev-libs/boost:0=
+ dev-libs/libpcre
+ sys-libs/zlib:0=
+ http2? ( net-libs/nghttp2:0= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
+ php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
+ php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
+ php_targets_php7-4? ( dev-lang/php:7.4[cli,sockets?] )
+ mysql? (
+ php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
+ php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
+ php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
+ php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug http2 libressl mysql sockets ssl"
+
+src_configure() {
+ # JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-swoole
+ $(use_enable debug)
+ $(use_enable http2)
+ $(use_enable mysql mysqlnd)
+ $(use_enable ssl openssl)
+ $(use_with ssl openssl-dir "${EROOT}/usr")
+ $(use_enable sockets)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ [[ -f tests/template.phpt ]] && rm tests/template.phpt
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}