summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-25 21:09:17 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-25 21:10:20 +0100
commit5baee74fbdce4cfcfc16da6700c613ddaa770cbb (patch)
tree0c867fe264589d68aa3984464907790756bfed0c
parentsci-biology/phyml: Modernise to EAPI 6 (diff)
downloadgentoo-5baee74f.tar.gz
gentoo-5baee74f.tar.bz2
gentoo-5baee74f.zip
sci-biology/transfac: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-biology/transfac/transfac-3.2-r1.ebuild (renamed from sci-biology/transfac/transfac-3.2.ebuild)27
1 files changed, 15 insertions, 12 deletions
diff --git a/sci-biology/transfac/transfac-3.2.ebuild b/sci-biology/transfac/transfac-3.2-r1.ebuild
index 9b6e76ce877b..7c98be79edae 100644
--- a/sci-biology/transfac/transfac-3.2.ebuild
+++ b/sci-biology/transfac/transfac-3.2-r1.ebuild
@@ -2,40 +2,43 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=6
+
DESCRIPTION="A database of eucaryotic transcription factors"
HOMEPAGE="http://www.gene-regulation.com/pub/databases.html"
SRC_URI="ftp://ftp.ebi.ac.uk/pub/databases/${PN}/${PN}32.tar.Z"
-LICENSE="public-domain"
+LICENSE="public-domain"
SLOT="3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="emboss minimal"
# Minimal build keeps only the indexed files (if applicable) and the documentation.
# The non-indexed database is not installed.
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emboss minimal"
DEPEND="emboss? ( sci-biology/emboss )"
-
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
+S=${WORKDIR}
src_compile() {
if use emboss; then
- echo
- einfo "Indexing TRANSFAC for usage with EMBOSS."
- EMBOSS_DATA=. tfextract -auto -infile class.dat || die \
- "Indexing TRANSFAC failed."
- echo
+ einfo
+ einfo "Indexing TRANSFAC for usage with EMBOSS"
+ EMBOSS_DATA="." tfextract -auto -infile class.dat || die "Indexing TRANSFAC failed"
+ einfo
fi
}
src_install() {
+ newdoc readme.txt README
+
if ! use minimal; then
insinto /usr/share/${PN}-${SLOT}
- doins *.dat || die
+ doins *.dat
fi
+
if use emboss; then
insinto /usr/share/EMBOSS/data
- doins tf* || die
+ doins tf*
fi
}