summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 15:11:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 15:11:46 +0100
commit5bbf33ab5c28f5577e7b56c07d93e166a85472fd (patch)
tree259aa0d5e4c1fd45fa8789e486fa54b19a4b0e65
parentdev-python/dep-logic: Remove old (diff)
downloadgentoo-5bbf33ab5c28f5577e7b56c07d93e166a85472fd.tar.gz
gentoo-5bbf33ab5c28f5577e7b56c07d93e166a85472fd.tar.bz2
gentoo-5bbf33ab5c28f5577e7b56c07d93e166a85472fd.zip
dev-python/django-debug-toolbar: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild38
-rw-r--r--dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch20
3 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 9d3db59fb928..663b6eb2985b 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,2 +1 @@
-DIST django_debug_toolbar-4.2.0.tar.gz 259709 BLAKE2B 81172bca569f6080710db2180650b0620670a4b4d2919d8b1694bf9f15425d9378f6cd0cbb852544fca0809388bb13867500a38c9046e1feaa241cde973936d9 SHA512 ff36d92132fd9338e88a2f078747c1e54e7633aecc6babea28ccb0c080b0beb99feccf1d1c00960ba109e3e6e4805562c36c6571842ea3baeda860c71ffcbd50
DIST django_debug_toolbar-4.3.0.tar.gz 261173 BLAKE2B d5332d205be3a08826ac8b1bf1cb1ed8cd06b66cd5efb203a4290c9e75aab96c822d46c93830182cf6bd6fe2b867e14d5a82d52f6f72aebeaa9aa8ff1bc4e558 SHA512 48e06187289fc92216e5d7c0a77f88ce2fd105eef5ae2bc8dd0d398929c86a9fe021ea1f88f03083174f846f7e43cd07353e1175694733bfa0d55e4aa612c7f3
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
deleted file mode 100644
index 31ff14e414eb..000000000000
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A configurable set of panels that display various debug information"
-HOMEPAGE="
- https://github.com/jazzband/django-debug-toolbar/
- https://pypi.org/project/django-debug-toolbar/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/html5lib[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-py312.patch )
-
-python_test() {
- "${EPYTHON}" -m django test -v 2 --settings tests.settings \
- || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch b/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
deleted file mode 100644
index 69a5558da31b..000000000000
--- a/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/tests/panels/test_profiling.py 2023-12-30 20:02:22.263807899 +0100
-+++ b/tests/panels/test_profiling.py 2023-12-30 20:03:44.655458186 +0100
-@@ -1,3 +1,6 @@
-+import sys
-+import unittest
-+
- from django.contrib.auth.models import User
- from django.db import IntegrityError, transaction
- from django.http import HttpResponse
-@@ -50,6 +53,10 @@
- self.assertNotIn("render", content)
- self.assertValidHTML(content)
-
-+ @unittest.skipUnless(
-+ sys.version_info < (3, 12, 0),
-+ "Python 3.12 no longer contains a frame for list comprehensions.",
-+ )
- def test_listcomp_escaped(self):
- self._get_response = lambda request: listcomp_view(request)
- response = self.panel.process_request(self.request)