summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-07-31 15:05:24 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-07-31 15:08:17 +0200
commit5bc065e3947b195203d5e1dc10764e91541ae8f4 (patch)
tree4f58f35c6e7ea7e3be00bb0ae944e32f7c4d57f9
parentvirtual/cron: remove vixie-cron provider (diff)
downloadgentoo-5bc065e3947b195203d5e1dc10764e91541ae8f4.tar.gz
gentoo-5bc065e3947b195203d5e1dc10764e91541ae8f4.tar.bz2
gentoo-5bc065e3947b195203d5e1dc10764e91541ae8f4.zip
dev-python/blessed: bump to 1.17.9, add Python 3.9 support
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/blessed/Manifest1
-rw-r--r--dev-python/blessed/blessed-1.17.9.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/blessed/Manifest b/dev-python/blessed/Manifest
index 18a3f4492a93..eaf41cc7a2da 100644
--- a/dev-python/blessed/Manifest
+++ b/dev-python/blessed/Manifest
@@ -1 +1,2 @@
DIST blessed-1.17.8.tar.gz 6697594 BLAKE2B be279f1962e8643fdd2f03c63292700ebcdd89f29163f72de89d649990663e9677391a134e19e97fc51c64341f2efc9dbb8a13a467f864c04341a55fe31a87c1 SHA512 fbdeea8159f535824600bd4e9b080998d0a8336731c1d53ff5b89c7488363d35b87752b8e424317f64f2b90aec3c62ce3368503b1a864a67c1de48245dc2fbbf
+DIST blessed-1.17.9.tar.gz 6648453 BLAKE2B 75de7585de7712cb4314ca22fd30ea811e446e1373ccd9a8750526e9fd0b5ea31d4bd0cedbcb35f7814bda32c75f8d58141beb32f131cc8fcfa127e89c255c25 SHA512 0ead3e3a4b96213acb2834fa8a0d8f0c590027a1d3bd49253ea58af9da55fd687beea6b5dfe3a8f7e6f9868967e24e468abcbe260a3cd55018f32d7b81a58d6c
diff --git a/dev-python/blessed/blessed-1.17.9.ebuild b/dev-python/blessed/blessed-1.17.9.ebuild
new file mode 100644
index 000000000000..e810dfdd33a9
--- /dev/null
+++ b/dev-python/blessed/blessed-1.17.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for making terminal apps using colors, keyboard input and positioning"
+HOMEPAGE="https://github.com/jquast/blessed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # Skip those extensions as they don't have a Gentoo package
+ # Remove calls to scripts that generate rst files because they
+ # are not present in the tarball
+ sed -e '/sphinxcontrib.manpage/d' -e '/sphinx_paramlinks/d' \
+ -e '/^for script in/,/runpy.run_path/d' \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # COLORTERM must not be truecolor
+ # See https://github.com/jquast/blessed/issues/162
+ # Ignore coverage options
+ COLORTERM= pytest -vv --override-ini="addopts=" \
+ || die "tests failed with ${EPYTHON}"
+}