summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-26 05:57:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-26 06:42:05 +0200
commit5bd107d9b4306502427f24f575a4ee38fa7b19d9 (patch)
treee0b3d1dd477abe3f547ef711135856af45d9614d
parentdev-python/numpydoc: Bump to 1.6.0 (diff)
downloadgentoo-5bd107d9.tar.gz
gentoo-5bd107d9.tar.bz2
gentoo-5bd107d9.zip
dev-python/python-utils: Bump to 3.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-3.8.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index bda97de1e4c6..de573c13be6a 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1,2 +1,3 @@
DIST python-utils-3.7.0.tar.gz 29654 BLAKE2B ff306a2ee3e84585081f504ad50f117294698c75dd4d5015db6cf9326796d69aaf63365ac5bbedb3af4d41e4f18b7a05437860bf41cdb870e43f1ba75e92628c SHA512 df3b33dbf213c7099a5a17166ac1e01e9044bf6bb364de96a4b182831ff3216fe37edb7f94cb66f8d2fcab42cea404a9c4f27142890ae0e7510363815f47ad41
DIST python-utils-3.8.0.tar.gz 30397 BLAKE2B 05fb02505b233bfc6e8128a59e076b6fd81ee90bf5eda5ccf6f5476cf2f1796381fe392e8bce6d2a074aae1408c7ab267f5aff746349215765542497c9ca3d4b SHA512 0fcb1358eb1659d500a10fd6a9e6339b2d006f50d1656e4fd20a65c993e194d30fe204434d94f53872364cd67c6dbf68c0ed30cb1063571a6b143f1145e71bff
+DIST python-utils-3.8.1.tar.gz 30545 BLAKE2B 9132387de0d12c51dbd4a7a3eda561fa9935c9fa86d76346e50e4ee9401065211a02bb45e89df402900263d28b115b761c2a8d7a2fe799866da20d4848f48451 SHA512 ccba9651cc99a8f4e3f13e7ff66a43a40d2e85bc735b6246524269495ff321225a0dcad9abd03ca9cb61b4b1b35a27009fac3fe87e3f748ffc5c87a956acd335
diff --git a/dev-python/python-utils/python-utils-3.8.1.ebuild b/dev-python/python-utils/python-utils-3.8.1.ebuild
new file mode 100644
index 000000000000..79f64316b1e5
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}