summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-12 17:06:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-12 18:15:19 +0200
commit5be844c556c7798bfa50df9da494d0d9f3296d6c (patch)
tree3ea481541302f5238ca2d5c35f00a45c994c2b04
parentdev-qt/qt3d: Add IUSE="vulkan" tied to dev-qt/qtgui, add slot op (diff)
downloadgentoo-5be844c5.tar.gz
gentoo-5be844c5.tar.bz2
gentoo-5be844c5.zip
kde-apps/umbrello: Patch out dev-qt/qtwebkit dependency, fix DEPENDs
- Update HOMEPAGE - kde-frameworks/kdelibs4support is being linked to Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/umbrello/files/umbrello-20.08.3-no-qtwebkit.patch105
-rw-r--r--kde-apps/umbrello/files/umbrello-20.08.3-unused-qtwebkit.patch25
-rw-r--r--kde-apps/umbrello/umbrello-20.08.2-r1.ebuild (renamed from kde-apps/umbrello/umbrello-20.08.2.ebuild)11
3 files changed, 135 insertions, 6 deletions
diff --git a/kde-apps/umbrello/files/umbrello-20.08.3-no-qtwebkit.patch b/kde-apps/umbrello/files/umbrello-20.08.3-no-qtwebkit.patch
new file mode 100644
index 000000000000..8f1a63675d84
--- /dev/null
+++ b/kde-apps/umbrello/files/umbrello-20.08.3-no-qtwebkit.patch
@@ -0,0 +1,105 @@
+From 0500feddb6ff02cd42624b0d3018c5292481b031 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Mon, 12 Oct 2020 11:46:24 +0200
+Subject: [PATCH] Disable defunct WelcomePage to get rid of QtWebKit
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 1 -
+ cmake/modules/ECMKDE4Macros.cmake | 2 +-
+ umbrello/CMakeLists.txt | 2 --
+ umbrello/uml.cpp | 2 +-
+ umbrello/umlappprivate.h | 5 ++++-
+ 5 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d2d897683..ac70ffe4e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -89,7 +89,6 @@ find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS
+ Test
+ Widgets
+ Xml
+- WebKitWidgets
+ )
+
+ # search packages used by KDE
+diff --git a/cmake/modules/ECMKDE4Macros.cmake b/cmake/modules/ECMKDE4Macros.cmake
+index 3de472295..28eb1c180 100644
+--- a/cmake/modules/ECMKDE4Macros.cmake
++++ b/cmake/modules/ECMKDE4Macros.cmake
+@@ -106,7 +106,7 @@ macro(find_package package)
+ #message("-- ${ARGV} --")
+ if("${package}" MATCHES "^(Qt5)")
+ #message("-- replaced by finding Qt4 --")
+- _find_package(Qt4 4.4.3 REQUIRED QtCore QtGui QtXml QtTest QtWebKit)
++ _find_package(Qt4 4.4.3 REQUIRED QtCore QtGui QtXml QtTest)
+ elseif("${package}" MATCHES "^(KF5)$")
+ #message("-- replaced by finding KDE4 --")
+ _find_package(KDE4 REQUIRED)
+diff --git a/umbrello/CMakeLists.txt b/umbrello/CMakeLists.txt
+index 264b25fde..22480642d 100644
+--- a/umbrello/CMakeLists.txt
++++ b/umbrello/CMakeLists.txt
+@@ -525,7 +525,6 @@ if(NOT BUILD_KF5)
+ Qt4::QtCore
+ Qt4::QtGui
+ Qt4::QtXml
+- Qt4::QtWebKit
+ ${LIBXML2_LIBRARIES}
+ ${LIBXSLT_LIBRARIES}
+ ${KDE4_KTEXTEDITOR_LIBS}
+@@ -549,7 +548,6 @@ else()
+ Qt5::Xml
+ Qt5::PrintSupport
+ Qt5::Svg
+- Qt5::WebKitWidgets
+ KF5::Archive
+ KF5::Completion
+ KF5::CoreAddons
+diff --git a/umbrello/uml.cpp b/umbrello/uml.cpp
+index 1e0be0c5a..98ce70aef 100644
+--- a/umbrello/uml.cpp
++++ b/umbrello/uml.cpp
+@@ -996,7 +996,7 @@ void UMLApp::initView()
+ m_d->createObjectsWindow();
+ #endif
+ m_d->createStereotypesWindow();
+- m_d->createWelcomeWindow();
++// m_d->createWelcomeWindow();
+
+ m_debugDock = new QDockWidget(i18n("&Debug"), this);
+ m_debugDock->setObjectName(QLatin1String("DebugDock"));
+diff --git a/umbrello/umlappprivate.h b/umbrello/umlappprivate.h
+index a85de1f22..b9d50a5c1 100644
+--- a/umbrello/umlappprivate.h
++++ b/umbrello/umlappprivate.h
+@@ -42,7 +42,7 @@
+ #include <QFileInfo>
+ #include <QListWidget>
+ #include <QObject>
+-#include <QWebView>
++// #include <QWebView>
+
+ class QWidget;
+
+@@ -151,6 +151,8 @@ public slots:
+
+ void createWelcomeWindow()
+ {
++ return;
++/*
+ QString file = findWelcomeFile();
+ if (file.isEmpty())
+ return;
+@@ -171,6 +173,7 @@ public slots:
+
+ viewWelcomeWindow = parent->actionCollection()->add<KToggleAction>(QLatin1String("view_show_welcome"));
+ connect(viewWelcomeWindow, SIGNAL(triggered(bool)), welcomeWindow, SLOT(setVisible(bool)));
++*/
+ }
+
+ void slotWelcomeWindowLinkClicked(const QUrl &url)
+--
+2.28.0
+
diff --git a/kde-apps/umbrello/files/umbrello-20.08.3-unused-qtwebkit.patch b/kde-apps/umbrello/files/umbrello-20.08.3-unused-qtwebkit.patch
new file mode 100644
index 000000000000..bb1fde2878e6
--- /dev/null
+++ b/kde-apps/umbrello/files/umbrello-20.08.3-unused-qtwebkit.patch
@@ -0,0 +1,25 @@
+From 5263f4e391c50c72e000da6c2bcf1123c28192e5 Mon Sep 17 00:00:00 2001
+From: "Friedrich W. H. Kossebau" <kossebau@kde.org>
+Date: Wed, 21 Jun 2017 14:05:28 +0200
+Subject: [PATCH] Remove finding WebKitWidgets, not used
+
+---
+ lib/kdev5-php/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/kdev5-php/CMakeLists.txt b/lib/kdev5-php/CMakeLists.txt
+index 2a40b48ae..6ef58b0c9 100644
+--- a/lib/kdev5-php/CMakeLists.txt
++++ b/lib/kdev5-php/CMakeLists.txt
+@@ -28,7 +28,7 @@ include(KDECMakeSettings)
+ include(GenerateExportHeader)
+ include(FeatureSummary)
+
+-find_package(Qt5 REQUIRED Core Widgets Test WebKitWidgets)
++find_package(Qt5 REQUIRED Core Widgets Test)
+ find_package(KF5 REQUIRED COMPONENTS Archive ThreadWeaver TextEditor I18n ItemModels KCMUtils)
+ find_package(KDevPlatform ${KDEVPLATFORM_VERSION} REQUIRED)
+ find_package(KDevelop-PG-Qt REQUIRED)
+--
+2.28.0
+
diff --git a/kde-apps/umbrello/umbrello-20.08.2.ebuild b/kde-apps/umbrello/umbrello-20.08.2-r1.ebuild
index 574a19707ac2..d1052ac66c7b 100644
--- a/kde-apps/umbrello/umbrello-20.08.2.ebuild
+++ b/kde-apps/umbrello/umbrello-20.08.2-r1.ebuild
@@ -12,8 +12,7 @@ VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="KDE UML Modeller"
-HOMEPAGE="https://kde.org/applications/development/org.kde.umbrello
-https://umbrello.kde.org"
+HOMEPAGE="https://kde.org/applications/en/umbrello https://umbrello.kde.org"
LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
@@ -26,7 +25,6 @@ RDEPEND="
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtprintsupport-${QTMIN}:5
>=dev-qt/qtsvg-${QTMIN}:5
- >=dev-qt/qtwebkit-5.212.0_pre20180120:5
>=dev-qt/qtwidgets-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=kde-frameworks/karchive-${KFMIN}:5
@@ -35,6 +33,7 @@ RDEPEND="
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kiconthemes-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
@@ -49,9 +48,9 @@ RDEPEND="
dev-util/kdevelop-pg-qt
)
"
-DEPEND="${RDEPEND}
- >=kde-frameworks/kdelibs4support-${KFMIN}:5
-"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-20.08.3-{no,unused}-qtwebkit.patch )
src_configure() {
local mycmakeargs=(