summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 08:11:38 +0000
committerSam James <sam@gentoo.org>2023-02-17 08:11:58 +0000
commit5bea0774a5d162537d3e9e64238b1289df80272b (patch)
tree1a7094458ce31c088b9ed144a334e6b8f55f98af
parentnet-wireless/crda: enable py3.11 (diff)
downloadgentoo-5bea0774a5d162537d3e9e64238b1289df80272b.tar.gz
gentoo-5bea0774a5d162537d3e9e64238b1289df80272b.tar.bz2
gentoo-5bea0774a5d162537d3e9e64238b1289df80272b.zip
dev-python/python-linux-procfs: add 0.7.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/python-linux-procfs/Manifest1
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-linux-procfs/Manifest b/dev-python/python-linux-procfs/Manifest
index 14c8b56d5cb8..21796eedb129 100644
--- a/dev-python/python-linux-procfs/Manifest
+++ b/dev-python/python-linux-procfs/Manifest
@@ -1 +1,2 @@
DIST python-linux-procfs-0.6.3.tar.xz 18808 BLAKE2B 02fdc0349dd456819f67f82d6836a44e3285e16d9654dd52b58ac7d86e48bc559feda18f105db7911ac5f670fd0e6cfd5c6cc69a958a3e8494813ff244f8b06f SHA512 18e42bf12456893740c5ec950ffcca86945b1ff202a6ea3ae6ac800145771a39b4ab7e8bbb440210d48d0fe9de646e334095afd0b20060e2e28ab3fa844f6140
+DIST python-linux-procfs-0.7.1.tar.xz 19104 BLAKE2B e6e495ecce77c1ea4c1580c2534e87f769a0057702648ee75bf89f5cbaa944012ba17e69c231977889b9b18d8e9b8d67261361b499ef8a567bed978a207d61ec SHA512 532613cd0feab1317131a3ec30e0730ed48415de333f1430573b7bf0eb5525222dc92db38dab6ff76c27ff10ac0a381975c329441b9ca6011e79bd637482056d
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
new file mode 100644
index 000000000000..89622b4136e5
--- /dev/null
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
+HOMEPAGE="
+ https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/
+ https://kernel.googlesource.com/pub/scm/libs/python/python-linux-procfs/python-linux-procfs/
+"
+SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} ./bitmasklist_test.py || die "Tests failed with ${EPYTHON}"
+}