summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-11-20 22:15:29 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-11-20 22:21:21 +0000
commit5bf1f7164689ec8919b7f8baf5d0d76207bf0f8c (patch)
tree0075441396e40a4583811d07522e226d7140cda2
parentwww-client/vivaldi-snapshot: Install icons with newicon (diff)
downloadgentoo-5bf1f7164689ec8919b7f8baf5d0d76207bf0f8c.tar.gz
gentoo-5bf1f7164689ec8919b7f8baf5d0d76207bf0f8c.tar.bz2
gentoo-5bf1f7164689ec8919b7f8baf5d0d76207bf0f8c.zip
www-client/vivaldi-snapshot: Other miscellaneous cleanups
Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--www-client/vivaldi-snapshot/vivaldi-snapshot-3.5.2110.3.ebuild32
1 files changed, 12 insertions, 20 deletions
diff --git a/www-client/vivaldi-snapshot/vivaldi-snapshot-3.5.2110.3.ebuild b/www-client/vivaldi-snapshot/vivaldi-snapshot-3.5.2110.3.ebuild
index 73a74a24df68..f69da1d681b9 100644
--- a/www-client/vivaldi-snapshot/vivaldi-snapshot-3.5.2110.3.ebuild
+++ b/www-client/vivaldi-snapshot/vivaldi-snapshot-3.5.2110.3.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
CHROMIUM_LANGS="
af
am
@@ -76,7 +77,8 @@ CHROMIUM_LANGS="
zh-CN
zh-TW
"
-inherit chromium-2 desktop multilib unpacker toolchain-funcs xdg
+
+inherit chromium-2 desktop unpacker xdg
VIVALDI_PN="${PN/%vivaldi/vivaldi-stable}"
VIVALDI_HOME="opt/${PN}"
@@ -103,9 +105,6 @@ KEYWORDS="-* ~amd64 ~arm ~arm64 ~x86"
IUSE="proprietary-codecs widevine"
RESTRICT="bindist mirror"
-DEPEND="
- virtual/libiconv
-"
RDEPEND="
dev-libs/expat
dev-libs/glib:2
@@ -136,33 +135,27 @@ RDEPEND="
proprietary-codecs? ( media-video/ffmpeg:0/56.58.58[chromium(-)] )
widevine? ( www-plugins/chrome-binary-plugins )
"
+
QA_PREBUILT="*"
-S=${WORKDIR}
+S="${WORKDIR}"
src_unpack() {
unpack_deb ${A}
}
src_prepare() {
- iconv -c -t UTF-8 usr/share/applications/${VIVALDI_PN}.desktop > "${T}"/${VIVALDI_PN}.desktop || die
- mv "${T}"/${VIVALDI_PN}.desktop usr/share/applications/${VIVALDI_PN}.desktop || die
-
- mv usr/share/doc/${VIVALDI_PN} usr/share/doc/${PF} || die
- chmod 0755 usr/share/doc/${PF} || die
+ # Rename docs directory to our needs.
+ mv usr/share/doc/{${VIVALDI_PN},${PF}}/ || die
+ # Decompress the docs.
gunzip usr/share/doc/${PF}/changelog.gz || die
# The appdata directory is deprecated.
mv usr/share/{appdata,metainfo}/ || die
- rm \
- _gpgbuilder \
- etc/cron.daily/${PN} \
- || die
- rmdir \
- etc/cron.daily/ \
- etc/ \
- || die
+ # Remove cron job for updating from Debian repos.
+ rm etc/cron.daily/${PN} ${VIVALDI_HOME}/cron/${PN} || die
+ rmdir etc/{cron.daily/,} ${VIVALDI_HOME}/cron/ || die
# Remove scripts that will most likely break things.
rm ${VIVALDI_HOME}/update-{ffmpeg,widevine} || die
@@ -176,9 +169,8 @@ src_prepare() {
}
src_install() {
- mv * "${D}" || die
+ mv */ "${D}" || die
dosym /${VIVALDI_HOME}/${PN} /usr/bin/${PN}
-
fperms 4711 /${VIVALDI_HOME}/vivaldi-sandbox
local logo size