summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-09-04 00:20:07 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-09-04 00:20:07 +0300
commit5bfc612fcf6f0fa77efd007f02ccbbcd5a199d63 (patch)
tree207713237c9a7f9035345ef9ab4b049e2ca2bcdb
parentdev-python/RecSQL: Version bump (diff)
downloadgentoo-5bfc612f.tar.gz
gentoo-5bfc612f.tar.bz2
gentoo-5bfc612f.zip
sci-chemistry/GromacsWrapper: Version bump
Package-Manager: Portage-2.3.47, Repoman-2.3.10
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild38
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild38
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.7.0.ebuild (renamed from sci-chemistry/GromacsWrapper/GromacsWrapper-0.5.1.ebuild)15
-rw-r--r--sci-chemistry/GromacsWrapper/Manifest4
4 files changed, 8 insertions, 87 deletions
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild
deleted file mode 100644
index 4c953dd73e3c..000000000000
--- a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-if [[ $PV = *9999* ]]; then
- scm_eclass=git-2
- EGIT_REPO_URI="https://github.com/orbeckst/${PN}.git"
- EGIT_BRANCH="develop"
- SRC_URI=""
- KEYWORDS=""
-else
- scm_eclass=vcs-snapshot
- SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-inherit eutils distutils-r1 ${scm_eclass}
-
-DESCRIPTION="Python framework for Gromacs"
-HOMEPAGE="https://orbeckst.github.com/GromacsWrapper/"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- >=dev-python/matplotlib-0.91.3[${PYTHON_USEDEP}]
- >=dev-python/RecSQL-0.3[${PYTHON_USEDEP}]
- >=sci-libs/scipy-0.9[${PYTHON_USEDEP}]
- "
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/0001-Drop-chmod-hack.patch"
-)
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild
deleted file mode 100644
index dc2488dd3b95..000000000000
--- a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-if [[ $PV = *9999* ]]; then
- scm_eclass=git-2
- EGIT_REPO_URI="https://github.com/orbeckst/${PN}.git"
- EGIT_BRANCH="develop"
- SRC_URI=""
- KEYWORDS=""
-else
- scm_eclass=vcs-snapshot
- SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-inherit eutils distutils-r1 ${scm_eclass}
-
-DESCRIPTION="Python framework for Gromacs"
-HOMEPAGE="https://orbeckst.github.com/GromacsWrapper/"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- >=dev-python/matplotlib-0.91.3[${PYTHON_USEDEP}]
- >=dev-python/RecSQL-0.3[${PYTHON_USEDEP}]
- >=sci-libs/scipy-0.9[${PYTHON_USEDEP}]
- "
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/0001-Drop-chmod-hack.patch"
-)
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.5.1.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.7.0.ebuild
index 3e946ea31dd4..55ff025bcf66 100644
--- a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.5.1.ebuild
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.7.0.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
if [[ $PV = *9999* ]]; then
- scm_eclass=git-2
- EGIT_REPO_URI="https://github.com/orbeckst/${PN}.git"
+ scm_eclass=git-r3
+ EGIT_REPO_URI="https://github.com/Becksteinlab/${PN}.git"
EGIT_BRANCH="develop"
SRC_URI=""
KEYWORDS=""
else
scm_eclass=vcs-snapshot
- SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/Becksteinlab/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
inherit eutils distutils-r1 ${scm_eclass}
DESCRIPTION="Python framework for Gromacs"
-HOMEPAGE="https://orbeckst.github.com/GromacsWrapper/"
+HOMEPAGE="https://gromacswrapper.readthedocs.io"
LICENSE="GPL-3 LGPL-3"
SLOT="0"
@@ -28,7 +28,6 @@ IUSE=""
DEPEND="
>=dev-python/matplotlib-0.91.3[${PYTHON_USEDEP}]
- >=dev-python/RecSQL-0.3[${PYTHON_USEDEP}]
>=sci-libs/scipy-0.9[${PYTHON_USEDEP}]
- "
+ dev-python/six[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
diff --git a/sci-chemistry/GromacsWrapper/Manifest b/sci-chemistry/GromacsWrapper/Manifest
index 6b8bc8231762..54c404a4d0ed 100644
--- a/sci-chemistry/GromacsWrapper/Manifest
+++ b/sci-chemistry/GromacsWrapper/Manifest
@@ -1,3 +1 @@
-DIST GromacsWrapper-0.3.1.tar.gz 1575486 BLAKE2B 3ffb89f1e2facc281c58b48e1acf50fe14d2f0e095ac59a1fc9a571118926fa3d054bfc3ee1debdc46f7ec09fcd60944de460933048d6cc9f10d0411bc246c1a SHA512 655dae431bf575963af58a5f75abe6703fe1ecdddba5839b671d9237ddee0e33ab19b528e89bcba4db9063fe30622d44e8f47c7b6452b4d1eed8c7400873a012
-DIST GromacsWrapper-0.3.2.tar.gz 1592147 BLAKE2B 5b04deab9ab8f19f4fee9c7f0d1a614e64996635a5c8923e2271f26dc3ff7a03886a0306199e894b48267adc8dfc2dd853aeb37860007b27edd2d0c2424a7b35 SHA512 a9e0abb5e7ad0c6831e23b6a8c09c6e4cc74b33d66cd17df8e00b876dc275dda11c3d3723565d8d58c45bdf6b2b00323bf85e24e2d5324a8d8b597cc3e5d78a4
-DIST GromacsWrapper-0.5.1.tar.gz 1247839 BLAKE2B acab6411167c68fe8e1761418ab6f96918fa0eda91a2de15ccebacaf47e7352455576b2666982c25f5a6af4f10a443b4f20a6887998b68f12b13e1cfb4b8e838 SHA512 43b6b47e24cbb118492495370b165eb4b0e7672ba4e1c868d3039a0ad0b9828058f30ab7344118c7b0e7dd166ac325ea2b3483bd28b8f65dd972a101a5b9facd
+DIST GromacsWrapper-0.7.0.tar.gz 1177718 BLAKE2B 88515b14ce85ecdf0323c3e4a68ac702cfc14569508be015fafc8192174af792507f6d10935aed2f969417ad34d5a1216688e9dce2f6dc6fc47529b87572d229 SHA512 74f6c5b84556b79ced128e48bf111cc40306b8854c8fcf53cab8f2fcf2dce56367e075c116f50aa1aa0947c83af0641bc78045e7d5035f2a8813f9709edce097