summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2019-11-06 18:18:14 +0100
committerKeri Harris <keri@gentoo.org>2019-11-06 18:19:00 +0100
commit5c004a80af1e6a2b6d3f6b7f71d233cbcfe1924c (patch)
tree87e73d43eb014ca436ea0b6899bfcccdd35a5665
parentmedia-sound/cadence-{0.9.0,9999}: new ebuild (diff)
downloadgentoo-5c004a80af1e6a2b6d3f6b7f71d233cbcfe1924c.tar.gz
gentoo-5c004a80af1e6a2b6d3f6b7f71d233cbcfe1924c.tar.bz2
gentoo-5c004a80af1e6a2b6d3f6b7f71d233cbcfe1924c.zip
dev-lang/yap: remove old version
Signed-off-by: Keri Harris <keri@gentoo.org> Package-Manager: Portage-2.3.76, Repoman-2.3.11
-rw-r--r--dev-lang/yap/Manifest1
-rw-r--r--dev-lang/yap/yap-6.3.3.ebuild118
2 files changed, 0 insertions, 119 deletions
diff --git a/dev-lang/yap/Manifest b/dev-lang/yap/Manifest
index 9718e707adf8..5114fab57305 100644
--- a/dev-lang/yap/Manifest
+++ b/dev-lang/yap/Manifest
@@ -1,3 +1,2 @@
-DIST yap-6.3.3-gentoo-patchset-11.tar.gz 6021 BLAKE2B d83682de9a6f095482db66f4fd5bb562739121b8502464d92fb784c634bfbfc020ae3ec55641aaeb8c0d52ce5534f7888bdd7d3d556f68c749b2f0ee35860764 SHA512 d9645a6f5c2b633fb5b61f8b6219ac69ae28e4f53f149fcdbb161cb7a8226aecab64f831a19e73876eb5056bb9efc3501fe792b6dca418a2a56b058ec658a2db
DIST yap-6.3.3-gentoo-patchset-12.tar.gz 6478 BLAKE2B 405f7a080c670ef1ca246bd60fc6a29aaff5e0c0b2323adef2eff7eb471a79e59a043c2348b8db0f9a70e7d858068cd4c5d51ad9ff13159186ff157e0272ffb1 SHA512 39dc3397ce59e34b4ee82ef9105c0493483f7db4b6018db5ca7f41b0af55f9102fa326bcb79cc3e766fa9faabda17807caf76cfdbbced7905b44749078ee8732
DIST yap-6.3.3.tar.gz 7879301 BLAKE2B 1b12a3113dd57634df64680726fd49575979b84126a7a9e1f4d1429be90e1b95599166151ffe62c9ef990ac3c32f57a1efae081b864fc22225c93d21807f412b SHA512 4ef45277ec84b6e072fa54afc7d6c18f11c3a0cdf477e35e35a0ce2181c9ff2e693f8735f63a1899373f6baf79ce0a972b37e1ae6ed8271bec60663f477bbe80
diff --git a/dev-lang/yap/yap-6.3.3.ebuild b/dev-lang/yap/yap-6.3.3.ebuild
deleted file mode 100644
index 8c631c424ae4..000000000000
--- a/dev-lang/yap/yap-6.3.3.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic java-pkg-opt-2 multilib
-
-PATCHSET_VER="11"
-
-DESCRIPTION="YAP is a high-performance Prolog compiler"
-HOMEPAGE="http://www.dcc.fc.up.pt/~vsc/Yap/"
-SRC_URI="http://www.dcc.fc.up.pt/~vsc/Yap/${P}.tar.gz
- mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
-
-LICENSE="Artistic LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="R debug doc examples gmp java mpi mysql odbc readline static threads"
-
-RDEPEND="sys-libs/zlib
- gmp? ( dev-libs/gmp:0 )
- java? ( >=virtual/jdk-1.4:= )
- mpi? ( virtual/mpi )
- mysql? ( virtual/mysql )
- odbc? ( dev-db/unixODBC )
- readline? ( sys-libs/readline:= sys-libs/ncurses:= )
- R? ( dev-lang/R )"
-
-DEPEND="${RDEPEND}
- doc? ( app-text/texi2html )"
-
-src_prepare() {
- cd "${WORKDIR}"
- EPATCH_FORCE=yes
- EPATCH_SUFFIX=patch
- epatch "${WORKDIR}"/${PV}
- rm -rf "${S}"/yap || die "failed to remove yap xcode project"
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
-
- local myddas_conf
- if use mysql || use odbc; then
- myddas_conf="--enable-myddas"
- else
- myddas_conf="--disable-myddas"
- fi
- if use mysql; then
- myddas_conf="$myddas_conf yap_with_mysql=yes"
- fi
- if use odbc; then
- myddas_conf="$myddas_conf yap_with_odbc=yes"
- fi
-
- econf \
- --libdir=/usr/$(get_libdir) \
- --disable-prism \
- --disable-gecode \
- $(use_enable !static dynamic-loading) \
- $(use_enable threads) \
- $(use_enable threads pthread-locking) \
- $(use_enable debug debug-yap) \
- $(use_enable debug low-level-tracer) \
- $(use_with gmp) \
- $(use_with readline) \
- $(use_with mpi) \
- $(use_with mpi mpe) \
- $(use_with java) \
- $(use_with R) \
- ${myddas_conf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use doc ; then
- emake html || die "emake html failed"
- fi
-}
-
-src_test() {
- # libtai package contains check.c which confuses the default
- # src_test() function
- true
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed."
-
- dodoc changes*.html README || die
-
- if use doc ; then
- dodoc yap.html || die
- fi
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples/chr
- doins packages/chr/Examples/* || die
- insinto /usr/share/doc/${PF}/examples/clib
- doins packages/clib/demo/* || die
- insinto /usr/share/doc/${PF}/examples/http
- doins -r packages/http/examples/* || die
- insinto /usr/share/doc/${PF}/examples/plunit
- doins packages/plunit/examples/* || die
- if use java ; then
- insinto /usr/share/doc/${PF}/examples/jpl/prolog
- doins packages/jpl/examples/prolog/* || die
- insinto /usr/share/doc/${PF}/examples/jpl/java
- doins packages/jpl/examples/java/README || die
- doins -r packages/jpl/examples/java/*/*.{java,pl} || die
- fi
- if use mpi ; then
- insinto /usr/share/doc/${PF}/examples/mpi
- doins library/mpi/examples/*.pl || die
- fi
- fi
-}