summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-01-18 18:11:16 +0200
committerMart Raudsepp <leio@gentoo.org>2019-01-18 18:22:52 +0200
commit5c008d5047fe5486f3f23d6a22b30c993afc200a (patch)
tree64e2192899a43e4417fbc53332216a927bc68590
parentnet-misc/gnome-online-miners: lock to tracker-1 (diff)
downloadgentoo-5c008d50.tar.gz
gentoo-5c008d50.tar.bz2
gentoo-5c008d50.zip
net-libs/gupnp-av: bump to 0.12.11
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--net-libs/gupnp-av/Manifest1
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.12.11.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/gupnp-av/Manifest b/net-libs/gupnp-av/Manifest
index 0a8e2df4c435..c9e259d624ae 100644
--- a/net-libs/gupnp-av/Manifest
+++ b/net-libs/gupnp-av/Manifest
@@ -1 +1,2 @@
DIST gupnp-av-0.12.10.tar.xz 370552 BLAKE2B 0ccbbbbf88ba48e926634efcf550924b77a8fec1a1e660dc4f6aabdeba12db87c7e2dd4ca6875e34ae313e90cb9ee715c7176f29d6456a68799b68fdcab763a0 SHA512 dbecef1f725dd05e1d4f7f9dede02f26a022d8d3c98ed2344d28746b74fb81703026df8cdd7ed0f3060b55a5da6d88def1e92a80e1f1892ad7c0806124ef5269
+DIST gupnp-av-0.12.11.tar.xz 373052 BLAKE2B 3c324f790f0ffbcbd6cbf3b95dfdaf9dce51c6bf7bea3051fd5ded31b930dd6ff7b77b16a297cf54a49e738c195fd208dd4e83961f5ee3d302dc84f37b36924c SHA512 f6fb8897ccdb589446d8c83c5fe66918f0f569a624287881aaf41d928e429e41f3306443e24ef4d43d3ddffb24da2ad2c058cd39211176558c9cd7acd7af0ff7
diff --git a/net-libs/gupnp-av/gupnp-av-0.12.11.ebuild b/net-libs/gupnp-av/gupnp-av-0.12.11.ebuild
new file mode 100644
index 000000000000..62aeb5dc34d2
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.12.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/2" # subslot: soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-1.36:= )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}