summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2015-11-27 15:24:54 -0500
committerJoe Sapp <nixphoeni@gentoo.org>2015-11-27 15:25:27 -0500
commit5c04c89d33aaa76dce05205ff8e39e2731519356 (patch)
tree22ad316c276b5735a6e33bbc4900093ee0df5a5a
parentnet-p2p/bitcoin-qt: version bump to 0.11.2 (diff)
downloadgentoo-5c04c89d33aaa76dce05205ff8e39e2731519356.tar.gz
gentoo-5c04c89d33aaa76dce05205ff8e39e2731519356.tar.bz2
gentoo-5c04c89d33aaa76dce05205ff8e39e2731519356.zip
app-misc/gourmet: Add patch to address gourmet pull request 824; also eliminates PIL support
See https://github.com/thinkle/gourmet/pull/824 . Package-Manager: portage-2.2.25
-rw-r--r--app-misc/gourmet/files/tostring-to-tobytes.patch26
-rw-r--r--app-misc/gourmet/gourmet-0.17.4-r1.ebuild61
2 files changed, 87 insertions, 0 deletions
diff --git a/app-misc/gourmet/files/tostring-to-tobytes.patch b/app-misc/gourmet/files/tostring-to-tobytes.patch
new file mode 100644
index 000000000000..e42c59403d51
--- /dev/null
+++ b/app-misc/gourmet/files/tostring-to-tobytes.patch
@@ -0,0 +1,26 @@
+diff --git a/gourmet/gtk_extras/ratingWidget.py b/gourmet/gtk_extras/ratingWidget.py
+index 0e01735..efa6463 100644
+--- a/gourmet/gtk_extras/ratingWidget.py
++++ b/gourmet/gtk_extras/ratingWidget.py
+@@ -135,7 +135,7 @@ class StarGenerator:
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,
+diff --git a/gourmet/plugins/browse_recipes/icon_helpers.py b/gourmet/plugins/browse_recipes/icon_helpers.py
+index 61c772c..2e7b08b 100644
+--- a/gourmet/plugins/browse_recipes/icon_helpers.py
++++ b/gourmet/plugins/browse_recipes/icon_helpers.py
+@@ -38,7 +38,7 @@ def get_pixbuf_from_image (image):
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,
diff --git a/app-misc/gourmet/gourmet-0.17.4-r1.ebuild b/app-misc/gourmet/gourmet-0.17.4-r1.ebuild
new file mode 100644
index 000000000000..e5a07f2aa476
--- /dev/null
+++ b/app-misc/gourmet/gourmet-0.17.4-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Recipe Organizer and Shopping List Generator for Gnome"
+HOMEPAGE="https://thinkle.github.com/gourmet/"
+SRC_URI="https://github.com/thinkle/gourmet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="-i18n -ipython pdf print spell sound web"
+
+RDEPEND=">=dev-python/pygtk-2.22.0:2[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.7.9-r1[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ i18n? ( dev-python/elib-intl[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-0.13.2[${PYTHON_USEDEP}] )
+ pdf? (
+ >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-poppler-0.12.1-r4[${PYTHON_USEDEP}]
+ )
+ print? (
+ >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-poppler-0.12.1-r4[${PYTHON_USEDEP}]
+ )
+ spell? ( >=dev-python/gtkspell-python-2.25.3-r1[${PYTHON_USEDEP}] )
+ sound? ( >=dev-python/gst-python-0.10.22-r1:0.10[${PYTHON_USEDEP}] )
+ web? ( >=dev-python/beautifulsoup-3.2.1-r1:python-2[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=dev-python/python-distutils-extra-2.37-r1[${PYTHON_USEDEP}]"
+
+PATCHES=( ${FILESDIR}/no-docs-0.17.0.patch ${FILESDIR}/tostring-to-tobytes.patch )
+DOCS=( ChangeLog CODING.md FAQ README.md TESTS TODO.md )
+
+python_prepare_all() {
+ # Modify these lines before copying them out
+ sed -i "s:base_dir = '..':base_dir = '/usr/share':" gourmet/settings.py || die
+ sed -i 's:data_dir = os.path.join(base_dir, "gourmet", "data"):data_dir = os.path.join(base_dir, "gourmet"):' gourmet/settings.py || die
+ sed -i 's:\(icon_base = os.path.join(data_dir,\) "icons",:\1 "gourmet",:' gourmet/settings.py || die
+ sed -i 's:\(locale_base = os.path.join(base_dir, "gourmet",\) "build",:\1:' gourmet/settings.py || die
+ sed -i 's:\(plugin_base = os.path.join(base_dir,\) "gourmet", "build", "share",:\1:' gourmet/settings.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ distutils-r1_python_prepare
+ sed -i "s:\(lib_dir = \)'../gourmet':\1'$(python_get_sitedir)':" gourmet/settings.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman gourmet.1
+}