summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-28 02:21:31 +0100
committerSam James <sam@gentoo.org>2023-09-28 02:21:31 +0100
commit5c12b485d94a4e670e3874ef15bc277384bfc6e7 (patch)
treea456f2817ffbcf064201bad69222bf5246b87089
parentapp-qemulation/qemu: Download subprojects in fetch phase (diff)
downloadgentoo-5c12b485d94a4e670e3874ef15bc277384bfc6e7.tar.gz
gentoo-5c12b485d94a4e670e3874ef15bc277384bfc6e7.tar.bz2
gentoo-5c12b485d94a4e670e3874ef15bc277384bfc6e7.zip
app-emulation/qemu: don't conditionally define phase
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index de4d90b78216..1f63912672aa 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -446,20 +446,22 @@ check_targets() {
popd >/dev/null
}
-if [[ ${PV} == 9999 ]]; then
src_unpack() {
- git-r3_src_unpack
- for file in ${A}; do
- unpack "${file}"
- done
- cd ${WORKDIR} || die
- for proj in "${!SUBPROJECTS[@]}"; do
- mv "${proj}-${SUBPROJECTS[${proj}]}" "${S}/subprojects/${proj}" || die
- done
- cd "${S}" || die
- meson subprojects packagefiles --apply || die
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ for file in ${A}; do
+ unpack "${file}"
+ done
+ cd "${WORKDIR}" || die
+ for proj in "${!SUBPROJECTS[@]}"; do
+ mv "${proj}-${SUBPROJECTS[${proj}]}" "${S}/subprojects/${proj}" || die
+ done
+ cd "${S}" || die
+ meson subprojects packagefiles --apply || die
+ else
+ default
+ fi
}
-fi
src_prepare() {
check_targets IUSE_SOFTMMU_TARGETS softmmu