summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-24 10:25:33 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-24 10:35:59 -0400
commit5c3134a02b10314f2ae352d12135351e73a11c19 (patch)
tree32627ddedae043eae7c493c9e6bc48da31c07ccf
parentapp-crypt/yubikey-manager: add USE=verify-sig support (diff)
downloadgentoo-5c3134a0.tar.gz
gentoo-5c3134a0.tar.bz2
gentoo-5c3134a0.zip
net-wireless/gnome-bluetooth: Version bump to 42.3
Closes: https://bugs.gentoo.org/846662 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-42.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 3fa67cbaa3d1..37f414c1553a 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1,2 +1,3 @@
DIST gnome-bluetooth-3.34.5.tar.xz 353936 BLAKE2B 40300752830f71d436591e22a64a282745d8419ee46de534f76c4871a86a4c8f7b2203e3ddc4ca08d26348b97bf4a68315802ffa09c69265c55001e4806c7f1e SHA512 48431b3d19083705a6623442c5cd2d6c14962cdf30fc599ba47dceb6612b80142af77e1b6df142b530cb1015638081a06de38a3034177e0d05a354c40f19d9e5
DIST gnome-bluetooth-42.2.tar.xz 302248 BLAKE2B 7ba16f86dd05bd4db2b02767f7a02b0f8c8154f28834795eba1dd3e45493b7cf26e0417fabe44dedb363abd94b62a40b1e2ab97c32e9ff9e0881b863a1954112 SHA512 79c1846eb084fa8a80b070e2c5731040d23bc9c4cdd2c6f36d4acba9b9eb5cb828a61540b82e3bb993befa8fde1704f089d539c82291f1a6a16444182dd97f73
+DIST gnome-bluetooth-42.3.tar.xz 303604 BLAKE2B bf73d31d6fd40bafa22133caac6a612951fd2b09cc7b1501df5d0256e6d769553d01a951b7ff731cab96669a7935fe41c50e15c4b2ec97cd347abc79b9efbe75 SHA512 e07aa4edc6ebe4ea2690d4271be75ec84bf3d38fb6f9f87d6833ef0a3c3015bc063ff091755761f554ae18e40eb2dd98ae0ed77163016e671d63b944c553c310
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-42.3.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-42.3.ebuild
new file mode 100644
index 000000000000..10052388292a
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-42.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org meson python-any-r1 xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="3/13" # subslot = libgnome-bluetooth-3 soname version
+IUSE="gtk-doc +introspection sendto test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=gui-libs/gtk-4.4:4[introspection?]
+ media-libs/gsound
+ >=gui-libs/libadwaita-1.1:1
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev:=
+ >=sys-power/upower-0.99.14:=
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+ sendto? ( !net-wireless/gnome-bluetooth:2 )
+"
+BDEPEND="
+ ${PYHTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep '
+ >=dev-python/python-dbusmock-0.26.0[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test; then
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ # Check for python is unconditional
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use sendto)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}