summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-12 21:55:04 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-12 21:55:04 +0200
commit5c480f18167ba10d2868a4b4366b195a5dc43749 (patch)
treea538d2e0b91f364db24a55e0892a9b037e8c9380
parentdev-util/uftrace: Add missing PYTHON_REQUIRED_USE (diff)
downloadgentoo-5c480f18.tar.gz
gentoo-5c480f18.tar.bz2
gentoo-5c480f18.zip
games-strategy/freeorion: Add missing PYTHON_*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild4
-rw-r--r--games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild3
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild3
3 files changed, 5 insertions, 5 deletions
diff --git a/games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild b/games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild
index e3471161e466..e827e00ef9ec 100644
--- a/games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild
+++ b/games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild
@@ -23,6 +23,8 @@ LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
SLOT="0"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
RDEPEND="
>=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
media-libs/freealut
@@ -37,11 +39,11 @@ RDEPEND="
sci-physics/bullet
sys-libs/zlib
virtual/opengl
+ ${PYTHON_DEPS}
!dev-games/gigi"
# Use bundled gigi as of freeorion-0.4.3
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
virtual/pkgconfig"
PATCHES=( "${FILESDIR}/${P}-backport-sdl2-include-dir-fix.patch" )
diff --git a/games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild b/games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild
index 2c29c8b5c266..3aea6bd3b5d9 100644
--- a/games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild
+++ b/games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild
@@ -48,10 +48,9 @@ RDEPEND="
virtual/opengl
)
sys-libs/zlib
-"
-DEPEND="${RDEPEND}
${PYTHON_DEPS}
"
+DEPEND="${RDEPEND}"
pkg_setup() {
# build system is using FindPythonLibs.cmake which needs python:2
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 2c29c8b5c266..3aea6bd3b5d9 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -48,10 +48,9 @@ RDEPEND="
virtual/opengl
)
sys-libs/zlib
-"
-DEPEND="${RDEPEND}
${PYTHON_DEPS}
"
+DEPEND="${RDEPEND}"
pkg_setup() {
# build system is using FindPythonLibs.cmake which needs python:2