summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2019-11-17 18:14:23 +0000
committerIan Whyman <thev00d00@gentoo.org>2019-11-17 18:14:43 +0000
commit5c5dbed26f4de217f8c2ae42aff0639aecdcd861 (patch)
tree930f89604d96abfb51725d45e8035bd2ac40a0af
parentpackage.mask: Last rite dev-libs/btparser (diff)
downloadgentoo-5c5dbed26f4de217f8c2ae42aff0639aecdcd861.tar.gz
gentoo-5c5dbed26f4de217f8c2ae42aff0639aecdcd861.tar.bz2
gentoo-5c5dbed26f4de217f8c2ae42aff0639aecdcd861.zip
net-libs/libupnp: Version bump 1.10
First steps towards removing the now unneeded 1.8 slotting Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.10.0-r100.ebuild47
-rw-r--r--net-libs/libupnp/libupnp-1.10.0.ebuild70
3 files changed, 118 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index a65c18d588b1..8f88afcf9229 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1,3 +1,4 @@
+DIST libupnp-1.10.0.tar.gz 786215 BLAKE2B b652251fe4f91179b855d5231466e026ce4a232a7b6196a3a1f01fb7163b0cf953a1cffeb4330c9734f001014cda2a0a1c3ac2d3600bcd78ad8eeb42b062ea61 SHA512 d42a42ace366a781ff29db4b91d1b0dc27138c60028629dae1608335085fbab0e22bcfa5744a8e6890d948f86b642945721226204a09f8ba3c9a49e1a5b6b2b5
DIST libupnp-1.6.21.tar.bz2 1245353 BLAKE2B ca9ff07f88cfc77c3e3f7250ec1de6fb8c1ad3a918f556a7d37a6e994b67d825608edd3fd788a5b5979de72e3b25288225af3b5b8c58f54395682eef50bfc2d2 SHA512 65a2989497b941dfa1f7ac09fe44267de4a5231af25a304f0f6e754c7cbb578bdcb3c500188b5ebfbff9f579099db7501817d45e1724ef8e384d6d918bcdcdeb
DIST libupnp-1.6.25.tar.bz2 722731 BLAKE2B 7f1850a235683ecd19bc377cd5c80c9d7ee8f0ded123dfc00d29551d2fd97fb873ce4c30ce0d26d562c57470c266a573c37fed4c0db159c65c56c673271adf92 SHA512 c1426c2f855f34a56b96761602a35989867918b556ecf9784c9ce9580f6c6083950004909831bad331f3a4dfb70ef1bd287e026c71bbfde2613f77fe05ab9e1f
DIST libupnp-1.8.4.tar.gz 783896 BLAKE2B 483ae5344b0677441a02d4666476090e00d0f7b7798e24a7dbe7ea10cd68f02644851ba17cff06033714dc9f2ddf7d9c5588e5a54693f14ad1a9782a7751480d SHA512 6d96dc0dcf187a425f3b60f4e750102331bd0a5bd452007e345eeacb63e9287ac213574c8071294809283ff8d8795433706ed2a14bae3d451605bf7a75e5a5bb
diff --git a/net-libs/libupnp/libupnp-1.10.0-r100.ebuild b/net-libs/libupnp/libupnp-1.10.0-r100.ebuild
new file mode 100644
index 000000000000..5d4c9a581d9b
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.10.0-r100.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+DOCS="ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.21-cflags.patch
+)
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install () {
+ default
+
+ use static-libs || prune_libtool_files
+}
diff --git a/net-libs/libupnp/libupnp-1.10.0.ebuild b/net-libs/libupnp/libupnp-1.10.0.ebuild
new file mode 100644
index 000000000000..2d629febf65e
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.10.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+DOCS="ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.21-cflags.patch
+)
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install () {
+ default
+
+ use static-libs || prune_libtool_files
+
+ # Slot samples
+ if $(use samples); then
+ for bin in combo ctrlpt device ; do
+ newbin "upnp/sample/.libs/tv_$bin" "tv_$bin-${SLOT}"
+ done
+ fi
+
+ # Slot includes
+ cd "${D}/usr/include" || die
+ mv upnp "upnp-${SLOT}" || die
+
+ # Slot pkgconfig
+ cd "${D}/usr/$(get_libdir)/pkgconfig" || die
+ mv libupnp.pc "libupnp-${SLOT}.pc" || die
+ sed -i -e "s#/upnp#/upnp-${SLOT}#" \
+ -e "s#lupnp#lupnp-${SLOT}#" \
+ -e "s#lixml#lixml-${SLOT}#" "libupnp-${SLOT}.pc" || die
+
+ # Slot symlinks
+ cd "${D}/usr/$(get_libdir)" || die
+ mv libupnp.so "libupnp-${SLOT}.so" || die
+ mv libixml.so "libixml-${SLOT}.so" || die
+}