summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-06 13:16:41 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-06 18:23:17 +0100
commit5c698fdcee36815c98b58b65eaa94b69e8e9e2c6 (patch)
tree6571b3e69dc81627768ba990778a6fce4bf84d64
parentdev-lang/fuzion: new package; add 0.080 (diff)
downloadgentoo-5c698fdcee36815c98b58b65eaa94b69e8e9e2c6.tar.gz
gentoo-5c698fdcee36815c98b58b65eaa94b69e8e9e2c6.tar.bz2
gentoo-5c698fdcee36815c98b58b65eaa94b69e8e9e2c6.zip
app-emacs/biblio: bump to 0.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/biblio/Manifest1
-rw-r--r--app-emacs/biblio/biblio-0.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/biblio/Manifest b/app-emacs/biblio/Manifest
index d2dd8a63ccb6..e613a05d179e 100644
--- a/app-emacs/biblio/Manifest
+++ b/app-emacs/biblio/Manifest
@@ -1 +1,2 @@
DIST biblio-0.2_p20210418.tar.gz 205374 BLAKE2B f649cd5130ce79fae346e7121e1be87d2b596a66ca23f27ccb33f0b2fce9bddfbbeda2a41c79084c91f359235dd3806befa1e2e86c6015df132657c24eb1f6b6 SHA512 5245386cd95c2334a49a139c93ec6107378ebd4154d0263f5b982d0a027c8cf116bf8f89d25348e0d82b540f6672889b3325df4fff3573f2262da493431f2a10
+DIST biblio-0.3.tar.gz 205899 BLAKE2B 27444fbfcd301f69965f851e6ec553c13d088cc9ad9a21494be7a416688ac1d1d56e18788bc3294a905e693f14c25ad8779a9c7792ced179e1e26b98453a196e SHA512 45489cf8edbc1b05785739fafa7d2a145e077b9b04e9985d682b482956f1eeef23bdf44c2ce83c472eab12edba2e78d6b9c6716280cb294c56648e422462a4a8
diff --git a/app-emacs/biblio/biblio-0.3.ebuild b/app-emacs/biblio/biblio-0.3.ebuild
new file mode 100644
index 000000000000..9105a8ebd6c4
--- /dev/null
+++ b/app-emacs/biblio/biblio-0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This package contains libraries: biblio-core and biblio
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Browse and import bibliographic references with Emacs"
+HOMEPAGE="https://github.com/cpitclaudel/biblio.el/"
+SRC_URI="https://github.com/cpitclaudel/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/dash"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/buttercup
+ app-emacs/noflet
+ app-emacs/undercover
+ )
+"
+
+ELISP_REMOVE="${PN}-pkg.el"
+
+DOCS=( README.md etc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ buttercup -L . -L tests --traceback full tests || die
+}