summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-08-19 19:21:00 +0200
committerSam James <sam@gentoo.org>2021-08-26 23:50:13 +0100
commit5c8d34c127412c5d8b4fd3dc13e970f265be211c (patch)
treecaec8424501877fa92240af92c50df76ead4a63b
parentnet-analyzer/scli: EAPI 7, ebuild improvements (diff)
downloadgentoo-5c8d34c127412c5d8b4fd3dc13e970f265be211c.tar.gz
gentoo-5c8d34c127412c5d8b4fd3dc13e970f265be211c.tar.bz2
gentoo-5c8d34c127412c5d8b4fd3dc13e970f265be211c.zip
sys-apps/busybox: Disable standalone shell mode with USE=make-symlinks
* Busybox has by default enabled CONFIG_FEATURE_PREFER_APPLETS and CONFIG_FEATURE_SH_STANDALONE which means it will bypass all PATH lookups and use its builtin applets. This is problematic as we sometimes might want to use the original program instead of Busybox applets, so let's disable those two options when building with USE=make-symlinks. This also enables users to disable a builtin by deleting the corresponding symlink. Closes: https://bugs.gentoo.org/729184 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/22038 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/busybox/busybox-1.33.1-r2.ebuild (renamed from sys-apps/busybox/busybox-1.33.1-r1.ebuild)8
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-apps/busybox/busybox-1.33.1-r1.ebuild b/sys-apps/busybox/busybox-1.33.1-r2.ebuild
index 19eb891b560f..8297592e5309 100644
--- a/sys-apps/busybox/busybox-1.33.1-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.33.1-r2.ebuild
@@ -141,6 +141,14 @@ src_configure() {
busybox_config_option n FEATURE_VI_REGEX_SEARCH
fi
+ # Disable standalone shell mode when using make-symlinks, else Busybox calls its
+ # applets by default without looking up in PATH.
+ # This also enables users to disable a builtin by deleting the corresponding symlink.
+ if use make-symlinks; then
+ busybox_config_option n FEATURE_PREFER_APPLETS
+ busybox_config_option n FEATURE_SH_STANDALONE
+ fi
+
# If these are not set and we are using a uclibc/busybox setup
# all calls to system() will fail.
busybox_config_option y ASH
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 19eb891b560f..8297592e5309 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -141,6 +141,14 @@ src_configure() {
busybox_config_option n FEATURE_VI_REGEX_SEARCH
fi
+ # Disable standalone shell mode when using make-symlinks, else Busybox calls its
+ # applets by default without looking up in PATH.
+ # This also enables users to disable a builtin by deleting the corresponding symlink.
+ if use make-symlinks; then
+ busybox_config_option n FEATURE_PREFER_APPLETS
+ busybox_config_option n FEATURE_SH_STANDALONE
+ fi
+
# If these are not set and we are using a uclibc/busybox setup
# all calls to system() will fail.
busybox_config_option y ASH