summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-28 08:18:26 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-28 08:24:23 +0100
commit5c91e6ea25435b4539b705d8fc7ea994e046e5ac (patch)
treef6a2ba041693942c7e9b0ccb446da4e0e27dd1cd
parentdev-ruby/rex-text: add ruby26 (diff)
downloadgentoo-5c91e6ea.tar.gz
gentoo-5c91e6ea.tar.bz2
gentoo-5c91e6ea.zip
dev-ruby/rex-exploitation: add 0.1.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ruby/rex-exploitation/Manifest1
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/Manifest b/dev-ruby/rex-exploitation/Manifest
index fdf95d75ea3d..5b5098026d13 100644
--- a/dev-ruby/rex-exploitation/Manifest
+++ b/dev-ruby/rex-exploitation/Manifest
@@ -1 +1,2 @@
DIST rex-exploitation-0.1.19.gem 79360 BLAKE2B 47043054ee9d08775c67d54b31861ad3a454a487bdc47beb135942e267040de7611308c62a23cbf853d190fb8f88c52998dfe3b24f66a698e76e273b6a69d822 SHA512 244de5259e3f4f645df09d1843c34d9ea4f9ea56ba22498495792f192b79a0451810f5c7e73516da5a455c27e61b66f8ccfbc485372946fcedd179b75ff9b31e
+DIST rex-exploitation-0.1.20.gem 79360 BLAKE2B 59dea65582647444e21cc1b0ae744c857b3007b8215c81244d37c6f3d8abcb1ef1b1d01428f306b4c5f6fdd1b3db0326de3c50fa38fa50505b4de9c05ba518e1 SHA512 e1df4ffde57ab40bf4b2492370d44bf064f39f657c7a8140416f51560a0be9b31ef95b1bdadaae6f6ec75c86e0978b41112a18caa1f69262c67945d3529f9990
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild
new file mode 100644
index 000000000000..e00da4173939
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/jsobfu:*
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}