summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2022-01-26 01:57:29 +0100
committerThomas Deutschmann <whissi@gentoo.org>2022-01-26 03:31:27 +0100
commit5cac77bb4df6bad3bcc9a5abf933090605e2d378 (patch)
tree3e00e206224150d029b0a18867f17e1e6ecdb637
parentmedia-gfx/imagemagick: bump to v6.9.12-35 & v7.1.0-20 (diff)
downloadgentoo-5cac77bb4df6bad3bcc9a5abf933090605e2d378.tar.gz
gentoo-5cac77bb4df6bad3bcc9a5abf933090605e2d378.tar.bz2
gentoo-5cac77bb4df6bad3bcc9a5abf933090605e2d378.zip
sys-apps/fwupd-efi: bump to v1.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-apps/fwupd-efi/Manifest1
-rw-r--r--sys-apps/fwupd-efi/fwupd-efi-1.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/fwupd-efi/Manifest b/sys-apps/fwupd-efi/Manifest
index 41334f096f0a..7dd592521b8d 100644
--- a/sys-apps/fwupd-efi/Manifest
+++ b/sys-apps/fwupd-efi/Manifest
@@ -1 +1,2 @@
DIST fwupd-efi-1.1.tar.gz 37079 BLAKE2B 6f9d97f969aa8c4e7f220e7914163ddff31fa841469b30e9ca73c76d49b753edcfd6e76df68b408533deb14e230240c9d15278eb8d7d490e45f10f28a0993cd6 SHA512 ee2c1039de87a3580cbe47bb5818015936ad7ef00b3bc8fff644c858387e5c5b3fe84e075e01ff9069218b04474774abee4a13261a2d1dd786e0e6d3bfe5833b
+DIST fwupd-efi-1.2.tar.gz 38867 BLAKE2B aa1a877db06dcf8347dff9411f9c9475b40e9a5f533949b254170c627869c61c5c3b17d9cbc9075af9d4f5c534befe1ab89f27d4684d1f7b701d50ab4cda2ff0 SHA512 c08a471ecdefdf40c94750954595ad1279da204e939517b62f223e0003a258840e7d4725ec74d77ccdf46906561d8ac987dcc67a9d3f6e9ba99219e16dd350de
diff --git a/sys-apps/fwupd-efi/fwupd-efi-1.2.ebuild b/sys-apps/fwupd-efi/fwupd-efi-1.2.ebuild
new file mode 100644
index 000000000000..e7bb5a79d7d4
--- /dev/null
+++ b/sys-apps/fwupd-efi/fwupd-efi-1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit meson python-any-r1 toolchain-funcs
+
+DESCRIPTION="EFI executable for fwupd"
+HOMEPAGE="https://fwupd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fwupd/fwupd-efi.git"
+else
+ SRC_URI="https://github.com/fwupd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DEPEND="sys-boot/gnu-efi"
+
+RDEPEND="!<sys-apps/fwupd-1.6.0"
+
+src_prepare() {
+ default
+
+ python_fix_shebang "${S}/efi"
+}
+
+src_configure() {
+ local emesonargs=(
+ -Defi-cc="$(tc-getCC)"
+ -Defi-ld="$(tc-getLD)"
+ -Defi_sbat_distro_id="gentoo"
+ -Defi_sbat_distro_summary="Gentoo GNU/Linux"
+ -Defi_sbat_distro_pkgname="${PN}"
+ -Defi_sbat_distro_version="${PVR}"
+ -Defi_sbat_distro_url="https://packages.gentoo.org/packages/${CATEGORY}/${PN}"
+ )
+
+ meson_src_configure
+}