summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-30 12:32:25 +0000
committerSam James <sam@gentoo.org>2022-10-30 12:32:25 +0000
commit5cc950a3a9d3ca757dd1e38bfff8318ffa798826 (patch)
tree28d24d75368445cc3f4bc2aa1e56fe3076e18a5d
parentdev-python/pyproj: enable py3.11 (diff)
downloadgentoo-5cc950a3.tar.gz
gentoo-5cc950a3.tar.bz2
gentoo-5cc950a3.zip
dev-python/pyproj: fix build w/ lld (respect libdir)
Closes: https://bugs.gentoo.org/730316 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pyproj/pyproj-3.4.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/pyproj/pyproj-3.4.0.ebuild b/dev-python/pyproj/pyproj-3.4.0.ebuild
index bffdc509c1a8..c0065b0c9ead 100644
--- a/dev-python/pyproj/pyproj-3.4.0.ebuild
+++ b/dev-python/pyproj/pyproj-3.4.0.ebuild
@@ -47,6 +47,13 @@ distutils_enable_sphinx docs \
dev-python/furo
distutils_enable_tests pytest
+src_configure() {
+ # Avoid greedily trying -L/usr/lib, etc
+ # https://github.com/pyproj4/pyproj/blob/main/setup.py#L76
+ export PROJ_LIBDIR="${ESYSROOT}/usr/$(get_libdir)"
+ export PROJ_INCDIR="${ESYSROOT}/usr/include"
+}
+
python_test() {
rm -rf pyproj || die
epytest -m "not network" test