summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-05-11 00:41:44 -0500
committerTim Harder <radhermit@gentoo.org>2019-05-11 00:50:44 -0500
commit5ce72a11698272faeaa9d45cea677bc7c15a8a21 (patch)
tree84e82ce8aa31933ab9f644990da68c559d285dbd
parentdev-ruby/aws-eventstream: add 1.0.3 (diff)
downloadgentoo-5ce72a11.tar.gz
gentoo-5ce72a11.tar.bz2
gentoo-5ce72a11.zip
dev-libs/libyaml: fix doc build support
Also, stop installing example code. Closes: https://bugs.gentoo.org/685594 Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-libs/libyaml/libyaml-0.2.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/libyaml/libyaml-0.2.2.ebuild b/dev-libs/libyaml/libyaml-0.2.2.ebuild
index b6373be87d00..84ef17996558 100644
--- a/dev-libs/libyaml/libyaml-0.2.2.ebuild
+++ b/dev-libs/libyaml/libyaml-0.2.2.ebuild
@@ -32,13 +32,13 @@ src_configure() {
econf $(use_enable static-libs static)
}
+src_compile() {
+ emake
+ use doc && emake html
+}
+
src_install() {
use doc && HTML_DOCS=( doc/html/. )
default
-
find "${D}" -name '*.la' -delete || die
-
- docinto examples
- dodoc tests/example-*.c
- docompress -x /usr/share/doc/${PF}/examples
}