summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-10-17 22:07:33 +0200
committerUlrich Müller <ulm@gentoo.org>2023-10-17 22:10:39 +0200
commit5cf61831fc6bff935c45805069b19316ff75ad1b (patch)
treedd9f56a29145575074238f41b0cbbb0eea7fd464
parentnet-misc/memcached: add 1.6.22 (diff)
downloadgentoo-5cf61831fc6bff935c45805069b19316ff75ad1b.tar.gz
gentoo-5cf61831fc6bff935c45805069b19316ff75ad1b.tar.bz2
gentoo-5cf61831fc6bff935c45805069b19316ff75ad1b.zip
app-doc/casting-spels-emacs: Update SRC_URI
Convert symlink to relative, other small updates to the ebuild. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19-r4.ebuild (renamed from app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild)18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r4.ebuild
index e3f9c9c18b3c..500d4bfd29b7 100644
--- a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r4.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit elisp-common
+inherit edos2unix elisp-common
DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
HOMEPAGE="https://www.lisperati.com/casting-spels-emacs/html/casting-spels-emacs-1.html
https://www.gnu.org/software/emacs/casting-spels-emacs/"
-SRC_URI="https://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
+SRC_URI="https://web.archive.org/web/20151231165906/https://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
S="${WORKDIR}/${PN}"
LICENSE="GPL-2+ FDL-1.2"
@@ -16,13 +16,13 @@ SLOT="0"
KEYWORDS="amd64 ~riscv x86"
RDEPEND=">=app-editors/emacs-23.1:*"
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
+
+PATCHES="${FILESDIR}/${P}-require-cl.patch"
src_prepare() {
- sed -i 's/\r$//' *.txt html/*.html {lisp,test}/*.el || die
- # needs cl extensions
- eapply "${FILESDIR}/${P}-require-cl.patch"
- eapply_user
+ edos2unix *.txt html/*.html {lisp,test}/*.el
+ default
}
src_install() {
@@ -33,5 +33,5 @@ src_install() {
docinto html/images
dodoc images/*.jpg images/*.png
dosym html/images /usr/share/doc/${PF}/images
- dosym ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
+ dosym -r ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
}