summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-01 21:39:38 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-01 21:39:58 +0100
commit5cf703235256f7329315a0f210f1a8a839118910 (patch)
treedb63999d7708ca68472e6c43f955b66ee29520b8
parentdev-python/tlslite: Bump (diff)
downloadgentoo-5cf70323.tar.gz
gentoo-5cf70323.tar.bz2
gentoo-5cf70323.zip
dev-python/llfuse: Bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-0.43.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index b7c9764a7d61..540cf3e21252 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1,3 +1,4 @@
DIST llfuse-0.40.tar.bz2 454032 SHA256 ee8b1125a6f2ab904d617d7602d86c0e3f69e40316cb1ae3abc33c218d3da857 SHA512 b568d14e181c316d592d01b7879d2b04c717759124d9462b7f848c251322a6a376881050d209d4cf3d0d6c5218ec1880cb64f19bd64b73f09fd06818447f3dfd WHIRLPOOL 3cfcd75a41ab39036b867e625248472a709ffdc61a588cbac47572455a6e3029f3d6592cbeb8e2b555a8c6f59729587a54c3373d3053e20f71a9b4f747ab87dc
DIST llfuse-0.41.tar.bz2 397155 SHA256 58079acce2ed03305bfea998cfad7c5d1815c85c263e0a21f692d4cdb7d01bde SHA512 5c8bd2cf4bb5dec624fa3aa96aeadd2583cdfa45a9331d62e395ca2007c96f8ae667dba40568e1a17f30157b1d0ca123fe68639d78d117cd83c2405649bf166d WHIRLPOOL da876ab8502682cf77e711e9d2d8be5e74e6aa0d8bc639e7b55afa2f76d15173e5651706310b3814ef3a820c6afe45a50134cfa61e5db93fab452c222ef9394b
DIST llfuse-0.42.1.tar.bz2 320282 SHA256 8ee9f190682d1c94e6522e77064fcdb4c7b07e71a6b9d1193ac1527972a98b59 SHA512 b87b26a3b19db954110248233f393c2c445d42b0fd89d83da3282d1f21f9ef6285721f3348e86d00d46584e3fc9896c6111d9573a103505476ab4f59d2c1b444 WHIRLPOOL c08d356e8170180aba87de9b5fb8f716a99865040582f90ec4a144c88b27f10f5e36ef4af20a29367cf3e4ae971a1a1b731e2717f7d1dece70754af49a4e535b
+DIST llfuse-0.43.tar.bz2 323979 SHA256 550c23c99ab1da711e816bdd980d588de174e143bc96cdb1f11c6ae6af35c7a1 SHA512 d3dfd33898eefd5774d007c960ac72f6c7a509ad18b5fb520a07f8c9b23414ba3f171e7d36a8703cdb2421270c3a3da82626cb6be7eb0cb3840d29506926c73f WHIRLPOOL 07b9e181f48d2f6d512436c775011b81f5db2e144809c9010e3a6cb263be75ebea1bebac7ecd02e242214b31feb18bafc0b996d36b257db152762769bdb5f127
diff --git a/dev-python/llfuse/llfuse-0.43.ebuild b/dev-python/llfuse/llfuse-0.43.ebuild
new file mode 100644
index 000000000000..1b07f647a9c0
--- /dev/null
+++ b/dev-python/llfuse/llfuse-0.43.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://python-llfuse.googlecode.com/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=sys-fs/fuse-2.8.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # use system setuptools
+ sed -i '/use_setuptools/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}