summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-01 06:21:01 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-01 08:53:53 +0200
commit5cfebe16e6e3613161bec4ea99e1ddeb0f6296ed (patch)
tree84059904156ab6f6aa4e37b3aa311620fd01c964
parentdev-python/cffi: Bump to 1.15.1 (diff)
downloadgentoo-5cfebe16.tar.gz
gentoo-5cfebe16.tar.bz2
gentoo-5cfebe16.zip
dev-python/nbclient: Bump to 0.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.6.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index 3994a720b465..0c5646226a51 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1,2 +1,3 @@
DIST nbclient-0.6.3.tar.gz 77571 BLAKE2B 41b96f8c174506a97b257b352e2614f023785137bf79d57d9bd4fd38942b54cc9db97bdf63c65579e67f88afd57ff81cbc798880080842e981797ee07be9f441 SHA512 bf267f3f49289cadcce412dc772f01dab5cd4d5a4ceb3fa12b076357d04191a15573d540773d47d58a14570fe219a9591ab539b917b52f3f7a902aac0493ba82
DIST nbclient-0.6.4.gh.tar.gz 78101 BLAKE2B 91a653eb1735fe1a43044f18da773bcb0c4afd485fe7bfd3630c8c6a80776c9ff7e4cb08130c4e3953f03832933c429e68d7383677d8e56c54b485d55b8c5469 SHA512 a953b40b314ce104b28dfb9178a004ca4726d8a5912c84c168bf71527ee224082d3910f11040b172b6e62683493978b9b10161b69cadbca48a5652a4f98b5009
+DIST nbclient-0.6.5.gh.tar.gz 78170 BLAKE2B 690eb6c9b70d43210da013b7f0a2cd7e0ae76bd737dd9860df555c95f91e167c17dc6bbf54a73f98c2cff37d8f69d7246d3a3a6c45a33ce4187c498e6fcb81b1 SHA512 1dabd799c3b0f51c5158c58ebdad6f13662a2970b863a9414731fb7a9c4268ebd83c86fdc11d5de25f2998b6b847bd62d0d227b2bb38440618f583b4fa2d4e87
diff --git a/dev-python/nbclient/nbclient-0.6.5.ebuild b/dev-python/nbclient/nbclient-0.6.5.ebuild
new file mode 100644
index 000000000000..cc41ec1e5d49
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.6.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.5[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)